Yay install brave error disk space (Solved) Thanks

I installed Archlabs trying to install Brave from yay and get this error message.
I have a 124 gb free space in the home folder. I don’t understand why ?

error: Partition / too full: 142853 blocks needed, 33148 blocks free
error: not enough free disk space
error: failed to commit transaction (not enough free disk space)
Errors occurred, no packages were upgraded.
error installing repo packages 

Have you tried clearing out your cached build directory, probably /tmp?

All I can think off.

Just tried that even cleaned the yay folder still the same error.
Plus the only way to boot Arch now is from Arch-Linux with Linux Linux fallback initramfs.

Do you have separate partitions for /home and / (root)?

The error is saying you don’t have enough space on / not /home so 124G free space in /home won’t help you.

1 Like

You may be better served by installing brave-bin opposed to building it?
When possible, I try to grab the bin

Thanks for replying brave bin is the version I use.

1 Like

post

$df -h

df -h
Filesystem Size Used Avail Use% Mounted on
dev 16G 0 16G 0% /dev
run 16G 19M 16G 1% /run
/dev/sda7 40G 38G 124M 100% /
tmpfs 16G 0 16G 0% /dev/shm
tmpfs 16G 8.0K 16G 1% /tmp
/dev/sda8 132G 919M 124G 1% /home
/dev/sda1 96M 87M 9.8M 90% /boot
tmpfs 3.2G 28K 3.2G 1% /run/user/1000

I can’t believe this sda7 is the system folder.

You’ve got some cleanup work to do

1 Like

It is; that’s the root file system. Brave (any application) will want to install files to /usr/bin, /usr/lib etc … and you only have 124M available.

It is the swap file 31gb how.

A typo or some other error during installation. Did you make a swap file or try to create a swap partition during the install? If it’s a file, you can delete and re-create a new swap file.

Where are /dev/sda2 - /dev/sda6 ? Please post the contents of /etc/fstab, and the results from:

lsblk

You probably have 16G RAM :grinning:

Anyway, either follow @PackRat suggestion to resize the swap file/disable swap, or use gparted to resize /dev/sda7 and /dec/sda8. The size of dev, run and tmp file systems are also abnormally large.

Thanks chroot & PackRat

I would never have guessed it would have been a swapfile, this was completely my fault as a swap file was make during the install. I don’t even need a bloody swapfile I have 32gb memory.
All is now normal.

df -h

Filesystem      Size  Used Avail Use% Mounted on
dev              16G     0   16G   0% /dev
run              16G   19M   16G   1% /run
/dev/sda7        40G  6.1G   32G  17% /
tmpfs            16G     0   16G   0% /dev/shm
tmpfs            16G  8.0K   16G   1% /tmp
/dev/sda8       132G  954M  124G   1% /home
/dev/sda1        96M   87M  9.8M  90% /boot
tmpfs           3.2G   32K  3.2G   1% /run/user/1000

lsblk

NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0 465.8G  0 disk
├─sda1   8:1    0   100M  0 part /boot
├─sda2   8:2    0    16M  0 part
├─sda3   8:3    0 132.7G  0 part
├─sda4   8:4    0   499M  0 part
├─sda5   8:5    0  40.5G  0 part
├─sda6   8:6    0 100.9G  0 part
├─sda7   8:7    0  40.5G  0 part /
├─sda8   8:8    0 134.4G  0 part /home
└─sda9   8:9    0  16.2G  0 part
sdb      8:16   0   3.6T  0 disk
├─sdb1   8:17   0   128M  0 part
└─sdb2   8:18   0   3.6T  0 part
sdc      8:32   0 232.9G  0 disk
└─sdc1   8:33   0 232.9G  0 part

I’m quad booting Arch,Archlabs,win10

Thanks so much again

2 Likes

I’m not very happy about the size of the boot partition that windows 10 made, only 100mb it use to be 512mb.

sda3=windows
sda5=Arch sys
sda6=Arch home
sda7=Archlabs sys
sda8=Archlabs home