Yaourt not working


#1

After installing AL 2018.03, the yaurt stopped working for me:

package-query: error while loading shared libraries: libalpm.so.10: cannot open shared object file: No such file or directory
package-query: error while loading shared libraries: libalpm.so.10: cannot open shared object file: No such file or directory

Please help me!


#2

I found this in the forum search… libalpm.so.10


#3

Thanks, but you do not know where you can find it?


#4

Did you check the comments?
There is a palliative solution there


#5

Sorry but I don’t speak English )
Google Translate help me )


#6

You’re not alone, I speak Brazil with the help of Google! hahaha

You will check the 2nd comment here and on the other link


#8

Thanks! I find solution!


#9

I have this error and I can not find libpalm, even if I do not give the solution to copy the file in / usr / lib

[don@don-pc ~]$ yaourt -Syau
package-query: error while loading shared libraries: libalpm.so.10: cannot open shared object file: No such file or directory
[sudo] password di don: 
:: Sincronizzazione dei database in corso...
 core è aggiornato
 extra è aggiornato
 community è aggiornato
 multilib è aggiornato
 archlabs_repo è aggiornato
package-query: error while loading shared libraries: libalpm.so.10: cannot open shared object file: No such file or directory

package-query: error while loading shared libraries: libalpm.so.10: cannot open shared object file: No such file or directory
No database errors have been found!
[don@don-pc ~]$ 

Here the correct solutions, but do not use them for archlabs

https://arcolinux.com/fixing-the-error-message-package-query-error-while-loading-shared-libraries-libalpm-so-10/


[Solved] Pacli - empty package list in "Install Package" option
#10

I did not use the Antergos tip, I used a command that ignored the dependencies and then managed to override


#11

I do not even use antergos, could you tell me what you did?
Where I find: libalpm.so.10


#12

Everything started with ffmpeg 2.7, x265 and another package I do not remember now, I tried to remove or revert the packages and the error Lib appeared, but it always showed ffmepeg, so I used sudo pacman -Rdd and I was able to remove and update

About Antergos, a member made available the file that pamcan 5.xxx seems to be removing when updating, I did not use this tip, I had already corrected.


#13

ok, so far I’ve solved that, installed pacman-contrib, downgrade and blocked old pacman version the update.
and yaourt now updates and not errors

[don@don-pc ~]$ yaourt -Syau
:: Sincronizzazione dei database in corso...
 core è aggiornato
 extra è aggiornato
 community è aggiornato
 multilib è aggiornato
 archlabs_repo è aggiornato
  dvdrip : Orfano 
 Altri pacchetti: - 42 / 42

==> Solo aggiornamenti dei pacchetti (nuova release):
aur/makemkv 1.12.2-1 1 -> 2

==> Aggiornamenti del software (nuova versione):
aur/etcher  1.3.1-1  -> 1.4.4-1

==> Continuare l'aggiornamento? [S/n]
==> [V]edi i dettagli dei pacchetti   Seleziona [M]anualmente i pacchetti
==> ---------------------------------------------------------------------
==> n
[don@don-pc ~]$ 

Get libalpm.so.10... HERE
#14

People are saying to rebuild package-query on the aur page. But ArchLabs seems to have a different version of package-query

: package-query and archlabs-package-query are in conflict. Remove archlabs-package-query? [y/N]

How to do it then?


#15

same problem here…

looks like AL uses “archlabs-package-query” which is in the archlabs repo and probably just needs to be rebuilt and bumped


#16

I wrote it for the moment you have to block the update of pacman and downgrade, read my post
as long as they do not create the new package of archlabs-package-query compatible with the new version of pacman


#17

This is now fixed with the recent update from @nate
Closing :smiley:


#18