Xorg update killed my laptop

This appears on the screen during boot after today’s update

1 Like

I think we need to see the entire X.Org log.

Use this command (as your normal user) to upload the file to a pastebin service:

curl -F 'f:1=<-' ix.io < ~/.local/share/xorg/Xorg.0.log

Then post the returned URL here.

I presume you’re not using a display manager?

I’m using startx as i never got it to work with any of the display managers.
By the way this was a fresh install because i thought i had ruined something so i did a fresh install
the reply from the text you gave me is ’ no such file or directory’
no problem i will try to install it again with a display manger

Thanks for the pastebin service command.

I would never go back to login manager myself, tty is the way to go for me…
.bash_profile = if [[ “$(tty)” == ‘/dev/tty1’ ]]; then exec startx fi

Another thing I like about tty if something goes wrong you go to tty2 and edit with vi and every thing else the terminal has the offer without trying to xstart .

1 Like

How strange, the screenshot references that file :confused:

We should be able to fix this without reinstalling. You don’t need to reinstall to add a display manager. You don’t need a display manager for X to work.

The problem was with xorg I did a reinstall and it got to the same point and stopped I noticed when I went to update my main pc that runs arch labs there was an xorg update,that was no problem on my dell optiplex 790,
I tried to install Obarun on the laptop and that gave me the same error,
Now it is running fedora 34 i3 with out any problems,I have had simpler problems with other distros before, so I think I will leave it as it is for now and look out for a second hand laptop that a is little newer than this one,
thanks for the help though everyone