Xfconf error with sudo user and Thunar

Hello boys & girls.

For some reason I am getting this error when attempting to use thunar as root. I have tried what I thought would fix things but the error persists. Any ideas or suggestions besides using a different file manager?

thunar: Failed to initialize Xfconf: Error spawning command line ?dbus-launch --autolaunch=0e818c4d332f47fb9bc87a7bcfbb3722 --binary-syntax --close-stderr?: Child process exited with code 1


(thunar:12366): thunar-WARNING **: 08:42:58.887: Name 'org.xfce.FileManager' lost on the message dbus.

(thunar:12366): thunar-WARNING **: 08:42:58.887: Name 'org.freedesktop.FileManager1' lost on the message dbus.
ThunarThumbnailer: failed to create proxy: Error spawning command line “dbus-launch --autolaunch=0e818c4d332f47fb9bc87a7bcfbb3722 --binary-syntax --close-stderr”: Child process exited with code 1

A search of that error message with Gibiru returned this:

Now that’s some strange shit. We got nothin. Maybe try something a bit less esoteric.

I’ll try something less esoteric :monkey_face:

Did you use:

sudo thunar

in a terminal? I tried that and got the same error message, but thunar still started.

You happen to be trying this on Manjaro? I found this on their forum:

You cannot do sudo thunar - it is system limitation. Use

thunar admin:/

No things work fine on manjaro… it’s on AL that the error appears. I, also, am unable to setting icon size and get thumbnails to work "always’.

Do you have OpenBox (if so), you must have some XFCE dependencies as well, check on with Font Configurations into Preferences as for the Fonts sizings.

As well as in your Thunar s Edit to Preferences , (File Manager Preferences), might do the trick here.

As for open as Root in Thunar, try this in terminal & see what it does;

pkexec thunar

Edit; check if this package is also installed.

dbus-X11

I am running the same setup on manjaro (5.4 kernel) debian (5.5 kernel) and al (5.5 kernel). The desktops (OB,xfce,bspwm) on all setups are identical; the version of Thunar on AL is 1.8.14 & manjaro 1.8.13. (I can’t check debian while writing this). My guess is that there is a bug in version 1.8.14 of Thunar that affects “Last Active View” when running Thunar 1.8.14 using 'pkexec thunar %f"…

That sux, check if it s installed;

dbus-X11

Guess that you were posting when I edited.

1 Like

Checking… dbus-x11 right now.

Ok cool

It seems to be fixed. I installed dbus_x11 which replaced dbus and now Thunar 1.8.14 on AL seems happy again. I must have borked something during the install process.

Anyway… I learned some stuff. Thank you @altman @PackRat!!!

I’m sure I’ll cause more breakage… not on purpose; I’m just skilled. :wink:

1 Like

lol, glad that we fixed this one, please mark it as solved as it can be of some help to other members in the future.

Edit; lol, I m also pretty good at borking my installs.

1 Like