ArchLabs Linux

Xfce4-panel --preferences

I have various old versions of archlabs where the panel entry is in the openbox menu.
In menu.xml, there is this entry as boot in the menu:
xfce4-panel --preferences
but when I click on the item this appears to me.
See photos

Maybe xfce4-panel has to be running for that to work?

Or maybe xfce4-panel is broken. Try starting it from a terminal and post any errors.

2 Likes

I don’t mean much, but that command should start xfce4-panel preferences
if I give
xfce4-panel
the xfce4 panel starts from the terminal
Thank
Cheers

^ This.

Does the command work if the panel is already running?

Hi @Head_on_a_stick,yes.

The preferences program uses dbus to change the panel without having to restart it.

If the panel isn’t already running then there is no dbus interface for the preferences program to use so it prints the error message.

2 Likes

So in the openbox session it doesn’t work.
Thanks for explaining the command Head.
Cheers

1 Like