Wont update

Hey guys,
So I have my archlab telling me I got 33 updates, but everytime I try (also tried with some other commands) I keep getting this ;

@archlabs ~ % sudo pacman -Syu :frowning:
:: Synchronizing package databases…
error: failed to update core (unable to lock database)
error: failed to update extra (unable to lock database)
error: failed to update community (unable to lock database)
error: failed to update multilib (unable to lock database)
error: failed to update archlabs_repo (unable to lock database)
error: failed to synchronize all databases

anybody else getting this?
cheers

Hey there

That might happen sometimes. If the problem doesn’t go away, you could always do this:

rm /var/lib/pacman/db.lck

After that you should be able to update the system normally.

2 Likes

Good call @eesau . I might had to clean the cache also, might help , in terminal:

sudo pacman -Scc

https://wiki.archlinux.org/index.php/Pacman

here

@synthia take a look at what @ector has posted. I think that may be of considerable help for your issue. We hope that it would work out for you.

rm /var/lib/pacman/db.lck

After that you should be able to update the system normally.

This.

wontupdate

Says the same? not sure of what I’m doing wrong?

And thanks for taking the time!

sudo rm /var/lib/pacman/db.lck

from wiki pacman
this must be root to work →# → rm /var/lib/pacman/db.lck

2 Likes

Hi there ector

Thanks a lot - that worked!

1 Like