ArchLabs Linux

Windows VMWare xfce Hangs at Boot

boot hangs at a blinking cursor.

if i rename .xinitrc and .zprofile, then i get the archlabs command prompt. But can’t get into xfce.

how to fix? do i need to config the virtual machine somehow?

thx

Check dmesg and the xorg log file for errors or failures. Not familiar with vmware so not sure. Check the xf86-video-vmware package is installed.

1 Like

thx for this. Prolly part of the solution, but not working yet.

this page says

if booting into multi-user.target or using an uncommon setup (e.g. multiple monitors), then vmtoolsd.service needs to be enabled.

but, when booted to commandline of vm, if i try to enable vmtoolsd.service, i get ‘doesn’t exist’.

when i pick ‘install tools’ from vmware menu, i get an alert asking if i want to unlock the CD drive. If i agree, i get:

image

Update: Found the proper install steps. Needs open-vm-tools. Trying now…
https://wiki.archlinux.org/index.php/VMware/Installing_Arch_as_a_guest#Installation

Was able to enable the vmtoolsd service, but still hanging at cursor on boot.

It also says that rootless xorg won’t work and that you need to edit the Xwrapper to force xorg to be run as root.

Seems like a lot of work when things like vbox and qemu have much easier setup, tried to use vmware in the past and it was just a headache

1 Like

i’m trying to use qemu on your suggestion. Can’t get a wifi connection.

Can you share your much easier setup?

The only way i found is much more complicated than with VMWare.
http://wiki.laptop.org/go/Talk:Using_QEMU_on_Windows#Networking_Issues_in_QEmu
(may be outdated)

also old, maybe irrelevant
http://sassan.me.uk/blog/qemu-and-openvpn-secure-and-convenient-remote-access-to-virtual-servers/

“The default network mode runs the network in the Windows users privilege space. It provides DHCP that assigns a 10.0.x.x address. It provides nat translation. ICMP Ping protocol does not work, but TCP & UDP work. Incoming port redirections can be provided in the start string.
For direct network connectivity the TAP driver can be installed from the OpenVPN installer. Bridge the created interface with the ethernet or wifi connections.”
http://www.digitalfoundations.com.au/blog/qemu-on-windows/

Have you tried running it as admin?

I don’t think virt-manager is available for windows and the only other gui I could find was last update in 2015 so it’s likely broken now. So maybe not the best option for a windows based vm.

Qemu really needs a gui frontend if you don’t know all the commands (like me), this is where something like virt-manager comes in, it does all the BS setup for you in the same way vbox or vmware does (pretty sure they all use kvm at the end)

On Arch based distros you can just do

pacman -S qemu virt-manager dnsmasq ebtables
systemctl enable libvirtd && systemctl start libvirtd

Now run virt-manager and setup a vm.


Lemme rummage up an old windows machine from somewhere and get back to you, feelin kinda lost and unable to offer anything of real help.

i’m running on a newish EFI box, with Windows Features disabled:

  • Virtual Machine Platform
  • Windows Hypervisor Platform

I have HAX accelerator installed according to these steps:
https://www.qemu.org/2017/11/22/haxm-usage-windows/

i created a 3GB qemu image:
labs.img

Starting the VM in admin powershell with:
qemu-system-x86_64.exe -cdrom D:\Downloads\OS\Linux\archlabs-2019.01.20.iso -boot order=d -drive file=D:\qemu\labs.img,format=raw -m 600M -accel hax

PowerShell reports:

HAX is working and emulator runs in fast virt mode.

(qemu:3384): Gtk-WARNING **: Could not load a pixbuf from /org/gtk/libgtk/theme/Adwaita/assets/bullet-symbolic.svg.
This may indicate that pixbuf loaders or the mime database could not be found.

archlabs live iso boots, and says:
-> ram: 47mb
Why not 600M?

ip link
1: lo <LOOPBACK...
2. ens3 <BROADCAST...

Why no eth0?

Attempting to enable wifi with:

systemctl enable dhcpcd@ens3.service
systemctl start dhcpcd@ens3.service

No errors, but pinging google.com fails with “0 received”.

i think i need to use the -nic or -netdev switch, so the guest can see the network.
https://qemu.weilnetz.de/doc/qemu-doc.html#Network-options

Documentation is fuzzy on the difference between the -nic and -netdev switches.

needed options might include:
net
host
hostname
dhcpstart

Bringing the topic back on track; I can’t seem to recreate this, I installed vmware player 15 on a fresh windows build and did a couple installs (no crazy setup, 2g ram and 2 cpus, everything else default) neither gave me any issue (aside from revealing a small installer bug with auto formatting, remember to update it with pacman -Syy archlabs-installer).

What display manager and other choices did you make so I can try finding the cause?

dw, or openbox, or xfce, with no display manager.
i just had success with virtualbox.

had to re-install on virtualbox, this time used efi.
now can’t boot at all.
i get some expected boot messages, but then hangs at a blank screen.

then i updated arch with pacman -Syu. Now getting emergency prompt at boot asking for admin password.

cannot boot archlabs installed to efi virtualbox.