Wifi strange behavour


#1

Happy New Archlabs!!

Yesterday I installed AL-2018.12.17 and it feels lighter and faster. Itś great!! I have a few small issues though! Homefolder has no folders for Downloads, Documents, and so on. Is that intensional? I personally like obmenu-generator, but It took me a couple of hours to get that working. (a few packages were missing). And finally to the strange thing. I have a bcm43228 wifi-card and according to arch-wiki (and other wikis) I should be using b43 or prop. broadcom-wl. I installed wl and did not blacklist at first because the driver takes care of that. I got interface but could not connect. It just tries to connect for a while and then stops. Spent a few hours on this last night, blacklisting, uninstalling, reinstalling etc. Today I tried b43 and now it works. The strange thing is that the driver in use is bcma, which isnt supposed to support bcm43228!
My old “summerinstall” of AL2018.07 I was able to use broadcom-wl (dkms) and it worked very well and with double speed!
A little lost here! Anyone with similar experience?

Womp


#2

@LionessAlana, is this issue you were having?


#3

Please post results from terminal; might help somehow;

inxi -N


#4

$ inxi -N
Network:
Device-1: Intel 82579LM Gigabit Network driver: e1000e
Device-2: Broadcom and subsidiaries BCM43228 802.11a/b/g/n
driver: bcma-pci-bridge

Womp


#5

I wonder if your network manager has installed correctly. But, as @altman suggested, install inxi. Then do a inxi -N and post the results. I have a feeling we may have to do modification to some of your default settings. I had trouble using WiFi through my VPN service. In order to get it to work, I had to make modifications to the network manager and the VPN config file.


#6

Hi and thanks for interest. Sofar I connect to vpn separately. (change that later) So I dont think vpn has anything to do with this problem.

Womp


#7

I think you should be using wl for that card, check the device ID to be sure:

lspci -knn | grep -iA2 net

BCM43228 should show [14e4:4359] as the device ID.

That command should also show the current driver in use, we don’t need inxi for that :slight_smile:


#8

Yeah! I know! Gentoo, Debian, Arch, Suse wiki all say wl! I think I have done this at least 100 times before. I have had problems before but not like this!

lspci -knn | grep -iA2 net

02:00.0 Network controller [0280]: Broadcom Inc. and subsidiaries BCM43228 802.11a/b/g/n [14e4:4359]
Subsystem: Dell BCM43228 802.11a/b/g/n [1028:0014]
Kernel driver in use: bcma-pci-bridge

Womp


#9

Are you sure the device was using the wl driver? How did you check?


#10

I used lspci -v.

wOMP


#11

https://wiki.archlinux.org/index.php/Broadcom_wireless#Interface_is_showing_but_not_allowing_connections?


#12

@womp If your wifi card is active, then it’s not likely to be a driver conflict. I had an issue recently where my card was active and could scan networks but not connect. When I tried to connect I would get a “connection not found” type error.

I fixed this by downgrading wpa_supplicant from version 2.7 to 2.6. The latest version has a bug that affects broadcom, at least. Good luck!


#13

Hi! I checked and my version is 2.6-1.
2.7? Testing repo?

Womp


#14

My God! Thank You! This fixed it!! Great!!

Womp


#15

Happy to hear it! That one kept me busy for a little while trying to figure it out!


#16

Hi @womp, no I said that I had that problem. I was just saying that I had that issue because of the network manager was causing my issues. I was saying that your issue may be with the network manager not allowing your WiFi to connect. But, it’s interesting that you can connect with your VPN service and yet having issues with your WiFi…Interesting bug with WPA_supplicant.
But I’m glad to hear you got it fixed. :blush: