Wifi not working

I can’t seem to get wifi working on ArchLabs (it works on Vanilla Arch)

Typing in “wifi-menu” outputs "Invalid interface specification).
Typing in “ip link” only outputs lo and eno1.

I’ve tried everything… any help?

May be a missing driver. Do you know what brand of wireless card?

If not, post the output of:


I’ve tried everything… any help?

What have you actually tried?

Network controller: Broadcom Inc. and subsidiaries BCM43224 802.11a/b/g/n (rev 01)

What does sudo ifconfig show ?

The command ifconfig doesn’t exist (I’m doing on a live usb).

So you haven’t done an actual install?

You posting from a live usb with a wired connection? You can install the broadcom wireless drivers from the command line, and I think it will carry over to the install.

looks like broadcom drivers got dropped; I don’t know if they aere added back for the Jan 2019 release.

Im posting from my phone

Sorry im on slackware at the moment.

From the arch wiki they deprecated net-tools / ifconfig in favour of iproute2.



so instead of ifconfig try ip addr

this will show us what devices are available and if they are up or down.

More info here, https://jlk.fjfi.cvut.cz/arch/manpages/man/ip.8

also this command will give a better picture of functionality.

lspci -knn | grep Net -A2

I have broadcom wifi as well but an older card that linux-firmware covers, your card might need non-free drivers and or dkms, something like broadcom-wl-dkms
In any case, you will need to tether your phone or get a ethernet connection to get wifi capability going.

It was such an hassle to install it using wifi, i just installed it using ethernet