Wifi card kernel problem


#1

Hi all,
I cant get my wifi card to work. I use Asus PCE-AC68 (BCM4360);

I get this pcie error when the kernel boots up, and I suspect it has to do with my wificard:

I got it working on other linux distros like manjaro and ubuntu, but not on archlabs using the broadcom-wl driver.

lspci | grep -i net shows that its detecting my wifi card:
lspci | grep -i net 20:53:29
05:00.0 Network controller: Broadcom Inc. and subsidiaries BCM4360 802.11ac Wireless Network Adapter (rev 03)

Any ideas?


#2

Hard or soft-blocked?

See here, bottom of page.

Check by

# rfkill list

… in terminal.


#3

Terminal returns this

└> % rfkill list 22:13:40
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no


#4

Buggers, was hoping that was it. Hang in there, perhaps another w/ more experience regarding wifi adapters will chime in.


#5

np mate, thanks a lot.


#6

Looks like the interface is there, check with ip link.

Why do you think the message refers to your card? I can’t see where you’re getting that from, the device ID is for the root port, AFAICT, but perhaps I’m being thick :smiley:


#7

Here they seem to talk about your mistake, but they understand a lot.
https://bbs.archlinux.org/viewtopic.php?id=242182
edit
maybe there is some solution here, but I’m not sure.
https://bbs.archlinux.org/viewtopic.php?id=236491

https://bbs.archlinux.org/viewtopic.php?id=225674


#8

not shure if my wificard is here. I just suspect it because my wifi card is inn a pci slot.

┌ ~
└> % ip link 23:32:07
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: wlp0s20f0u3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DORMANT group default qlen 1000
link/ether 10:fe:ed:27:e6:db brd ff:ff:ff:ff:ff:ff
┌ ~


#9

i tried many solutions from the arch forums, none did work. But thanks.


#10

The forums are very hit-n-miss imo, have you followed the wiki and blacklisted the modules in question?

https://wiki.archlinux.org/index.php/Broadcom_wireless

Take note of the fine print

  • BCM4306 rev.3, BCM4311, BCM4312 and BCM4318 rev.2 have been noticed to experience problems with b43-firmware . Use b43-firmware-classicAUR for these cards instead.

#11

have you tried this?
Open /boot/grub/grub.cfg and add pci=nomsi


#12

I even blacklisted the drivers i did not need. but still it did not work. The device did not appear in the list of
for wifi network devices, and still was loading bcm driver in the kernel, drivers even tough i disabled them. I will try the last solution soon.


#13

I will try, but i have to get some work done, I will switch back to ubuntu in the meantime.