What could be causing my computer to stutter?

Hey all,

For the past few weeks, I’ve noticed my computer stuttering randomly whenever I would use it. The screen will freeze for a few seconds, but the audio will be fine. For more graphically demanding applications such as game like Civ 5, stuttering is much more frequent and the audio also freezes momentarily. My whole screen will freeze for a couple seconds even when I press tab on a termite terminal for autocomplete. I’m pretty sure this isn’t an Archlabs specific problem, since I first noticed this problem when I was on Fedora 28 (I’m still asking here since this is the nicest linux/PC community & forum that I know :slight_smile: ). I ran “inxi -Fxz” in a terminal and here’s the output, I figured it would be useful:

System:    Host: archlabs Kernel: 4.17.6-1-ARCH x86_64 bits: 64 compiler: gcc v: 8.1.1
       Desktop: Openbox 3.6.1 Distro: ArchLabs Linux
Machine:   Type: Laptop System: Hewlett-Packard product: HP ZBook 15 v: A3009DD10303
       serial: <filter>
       Mobo: Hewlett-Packard model: 1909 v: KBC Version 94.55 serial: <filter>
       BIOS: Hewlett-Packard v: L70 Ver. 01.33 date: 07/21/2015
Battery:   ID-1: BAT0 charge: N/A condition: 79.3/79.3 Wh (100%) model: Hewlett-Packard Primary
       status: Unknown
       ID-2: BAT1 charge: 69.5 Wh condition: 72.9/72.9 Wh (100%)
       model: Hewlett-Packard Travel status: Unknown
CPU:       Topology: Quad Core model: Intel Core i7-4700MQ bits: 64 type: MT MCP arch: Haswell
       rev: 3 L2 cache: 6144 KiB
       flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 38333
       Speed: 1069 MHz min/max: 800/3400 MHz Core speeds (MHz): 1: 1167 2: 1620 3: 1332
       4: 1971 5: 1322 6: 1036 7: 1488 8: 1178
Graphics:  Card-1: NVIDIA GK107GLM [Quadro K1100M] driver: nouveau v: kernel bus ID: 01:00.0
       Display: x11 server: X.Org 1.20.0 driver: nouveau unloaded: fbdev,modesetting,vesa
       resolution: 1920x1080~60Hz
       Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:     Card-1: Intel 8 Series/C220 Series High Definition Audio driver: snd_hda_intel
       v: kernel bus ID: 00:1b.0
       Card-2: NVIDIA GK107 HDMI Audio driver: snd_hda_intel v: kernel bus ID: 01:00.1
       Card-3: C-Media type: USB driver: snd-usb-audio bus ID: 3:5
       Sound Server: ALSA v: k4.17.6-1-ARCH
Network:   Card-1: Intel Ethernet I217-LM driver: e1000e v: 3.2.6-k port: 6040 bus ID: 00:19.0
       IF: enp0s25 state: down mac: <filter>
       Card-2: Intel Centrino Advanced-N 6235 driver: iwlwifi v: kernel bus ID: 5c:00.0
       IF: wlo1 state: up mac: <filter>
Drives:    Local Storage: total: 465.76 GiB used: 49.41 GiB (10.6%)
       ID-1: /dev/sda vendor: Toshiba model: MK5061GSYN size: 465.76 GiB
Partition: ID-1: / size: 368.24 GiB used: 49.41 GiB (13.4%) fs: ext4 dev: /dev/sda3
       ID-2: swap-1 size: 31.61 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda4
Sensors:   System Temperatures: cpu: 55.0 C mobo: 54.0 C gpu: nouveau temp: 54 C
       Fan Speeds (RPM): N/A
Info:      Processes: 188 Uptime: 19m Memory: 7.73 GiB used: 1.37 GiB (17.7%) Init: systemd
       Compilers: gcc: 8.1.1 Shell: zsh v: 5.5.1 inxi: 3.0.17

Thanks a lot guys!

Graphics issue. Looks like your running the nouveau driver for your Nvidia card. Have you tried installing the Nvidia drivers? Did you install Nvidia drivers with Fedora?

How old is that laptop?

2 Likes

It s why I love to see computer spex around, easier to pinpoint issues one is having.

1 Like

I tried a while ago and everything on my screen became zoomed in (on fedora). I’ll try installing nvidia drivers again today though. I’ll keep you all posted.

Edit: the laptop is 4-5 years old

Alright, I’ve installed nvidia drivers, and the stuttering seems to be gone. However, I’ve run into the old problem of some fonts being too big. I tired setting my dpi to 96 in the fonts section of the setting manager, but there are still some fonts that are larger than a newspaper headline. I’ve attached a link to a screenshot here

the huge fonts are also in applications such as firefox, where all fonts are big.

Thanks a lot!

Edit: running “xrandr --dpi 96” does not help either, and doesnt do anything

Based upon your scrot, the only fonts I see affected are openbox. Have you checked your font settings under “appearance” in ObConf?

Yeah, they’re all at a reasonable font size (size 10), and reducing them does get rid of the problem, but i feel like there is a better way to resolve this then changing the font size. I’m currently googling and digging around my computer to find ways to change the dpi for openbox only, since obconf didn’t have an option to do that.

obconf will change the font sizes for the window manager (titlebars, menus, etc …)

Other fonts in gui applications can be set with the ArchLabs settings editor (can’t get on the ArchLabs computer at the moment). ArchLabs uses the xfce settings editor, it will be on the default menu under Preferences. You can set the font size, type, dpi, antialias etc … to your liking there.