Weird CTRL+ALT+DEL thing

Sometimes pressing CTRL+ALT+DEL yields not the shutdown menu, but an archlabs logo, and some weird green hilighting pinwheel… What is this thing? Can I utilize it?

I think that is i3lock. It’s your lock screen. The green pinwheel is indication that you are entering characters of your password :slight_smile:

1 Like

Because the lock screen is triggered. You can remove the shortcut settings from Settings --> Keyboard --> Shortcuts. Enjoy.:grinning:

1 Like

=O oh! okay. I just wasn’t really sure what it was. I guess I don’t reallly mind it.

change key on openbox rc.xml

 </action>
    </keybind>
    <keybind key="C-A-Delete">
      <action name="Execute">
        <command>oblogout</command>
      </action>

reconfigure openbox and restart system

It’s not the logout thing I wanted to change… It was the “lockscreen” thing. It pops up sometimes when I hit ctrl-alt-delete… but never when I close my laptop and open it again… where it would actually be useful.

Also… what do you mean reconfigure openbox?

I removed the keyboard command for locking it using CTRL+ALT+DEL

That seems a little counter intuitive to have two different shortcuts mapped to the same key combo.

Also how can I use i3lock-fancy to lock my screen when I shut the lid and reopen it?

Sorry, I did not remember that you use i3.
I do not use i3, but I think someone who uses it can help you

I don’t use i3… it seems to be something included by default :open_mouth:

I guess I’ll have to figure it out. But that’s okay, that’s half the fun anyways :slight_smile:

I have no idea where the thing came from. But I disabled it from being activated by CTRL+ALT+DEL. Weird that it’s set to conflict with oblogout automatically.

@Xase, post your rc.xml and I’ll take a looksee.

1 Like

Some people wanted it bound to Ctrl-Alt-Del but we’ve always had it bound to Super-x, they don’t conflict (I don’t think) just two binds for the same action.

https://pastebin.com/VGkRYZjy

Sorry for the delay, I have a couple projects I’m working on.

I removed the key binding as @ArchZ suggested, and that removed it from triggering while trying to access the Logout/shutdown box.

All I know is it was triggering when I wasn’t sure what it even was, and did a shutdown to escape out of it.