Web-links in Geary Open in Non-Default Browser, xfce

i have my default browser set to Opera in “Preferred Applications”.

But, when i click a weblink in a geary message, it opens in netsurf.

How to fix?

thx

Check the preferences for Geary and see if there is a browser option, or some other “open links with” option.

Nope, it’s not a geary thing. I already got told by geary team. They are mean.

Anyway, found the fix in the arch bbs.

  • xfce set preferred browser to leafpad or something else
  • log out/in
  • open opera or preferred browser.
  • let browser set itself as preferred browser.
  • log out/in