VSCode is not starting lib issue

Hi all,

I am getting a very confusing issue

I am installing
xorg ( all 48 recommended pakages)
lightdm, lightdm-gtk-greeter
i3-wm
code ( vscode )

when I run the code I am getting this
electron11: error while loading shared libraries: libicui18n.so.69: cannot open shared object file: No such file or directory

even after installing icu and reboot still have the same issue

any opinions ?

Please make sure you update the system pacman -Syyu, I installed code to try and it works as expected (like trash).

2 Likes

:laughing:

electron

but other than than that I will give it a try :slight_smile:

It’s not just electron.

Any word? I can’t see any reason it wouldn’t work on your system vs mine as long as everything is current.

To avoid issues like this it’s a good practice to update before installing any packages if possible, programs like baph (installed by default with AL) do just this.

i think my issue is something i am installing ( via ansible role ) when I install xorg VS when I do it manually

I don’t think the issue is xorg related if you’re installing it all via pacman.

so

as very well said on the first answer running a pacman -Syyu solved the issues
In particular, the package icu-69.1-1 got installed

My real issues were that I thought that my ansible role was doing a full upgrade

Proper Layer 8 :smiley: :smiley:

I’m not very knowledgeable in this area (ansible) and don’t really know what it is, but I do know that you should be running native packages installed with pacman on Arch based systems like AL. If trying to install/update packages through other means (scripting, etc…) you should always do

pacman -Syyu <package>

Please mark the response that solved the issue so others can find it easily and the thread will be marked as solved.

1 Like