Volume Icon

Hi, I am trying to be helpful here, sorry if I am not!

When I installed Openbox AL right clicking on the Volume icon and selecting open mixer just gave a screen flicker (p’raps a window opening and shutting?)

I had to change the external mixer setting command to pavucontrol from what it was by default (cant remember exactly but it was something with alsamixer)

I didnt install pauvcontrol or anything so it must be default setup?

Minor niggle, but as I said, just trying to help as with my level of expertise I dont get much chance to do that :rofl:

1 Like

Change ~/.config/volumeicon/volumeicon to have this line instead.

onclick=xterm -e 'pauvcontrol'

Thanks, but I dont understand why.
That is just the same as changing the icon preferences to xterm -e ‘pauvcontrol’ isnt it?
With that it doesnt work
with it just set as pauvcontrol it works
Is that because I have xfce4 terminal set as default?

pavucontrol does not need to be launched from a terminal.

Yes, and I suspect it did not work because you do not have xterm installed. Change the command to:

xfce4-terminal -e pavucontrol

and it should work, but launching from a terminal is not required for pavucontrol.

Default terminal doesn’t matter in this situation since pavucontrol does not need to be launched from a terminal. The default application alsamixer is ncurses based so launching from a terminal is required.

2 Likes

It’s launched from volumeicon. See ~/.config/volumeicon/volumeicon

2 Likes

in my xfce4 terminal xterm opens xterm

But both of below (with or without quotes) just opens it for a very short flicker then it shuts
[Edit: the first one below didnt work because of typo pauvcontrol - with pavucontrol it works. All clear to me now - thanks!]

xterm -e ‘pauvcontrol’
xterm -e ‘alsamixer’

However,


xfce4-terminal -e pavucontrol

opens xfce4 terminal and pauvcontrol (I realise I dont need terminal)

But


xfce4-terminal -e alsamixer

opens terminal but gives a failed to open child error

And


alsamixer

in my xfce4-terminal says command not found

For me, none of this matters since its working by just writing pauvcontrol in the icon prefs, I just thought that since I installed from the iso and didnt change much that this was some minor error (in that the default setting for vol icon is alsamixer but it doesnt seem to be installed by default whereas pauvcontrol is) that you might want to correct. Like I said, just trying to help.
But I think I am now just making confusion, as I dont know enough. about thst which I am talking :rofl:
Sorry bout that
Good intentions and all that

AL uses pulseaudio for sound so alsamixer will nott be installed. Will have to make a mental note to include a simple ~/.config/volumeicon/volumeicon in the skel for the next release. Good catch on that; thanks.

Don’t use the single quote.

xterm -e pavucontrol
2 Likes