Virtualbox - VM's get stuck at 20%

I have followed the Arch Wiki to install virtualbox, by doing the following:

leigh@T16-AL ~ % uname -a
Linux T16-AL 6.2.12-arch1-1 #1 SMP PREEMPT_DYNAMIC Thu, 20 Apr 2023 16:11:55 +0000 x86_64 GNU/Linux

yay virtualbox
yay virtualbox-host-modules-arch
sudo gpasswd -a leigh vboxusers
yay virtualbox-guest-iso
yay virtualbox-ext-oracle

Virtualbox starts fine, but when I make a new VirtualMachine (VM), on starting it says ‘powering VM up …’ & ‘Starting virtual machine’ but it goes to 20% and sticks there with whirly mouse cursor and I have to kill the VirtualBoxVM process

The same happens for imported VM’s that worked on my previous machine.

I am using i3 &

leigh@T16-AL ~ % neofetch
                   -`                    leigh@T16-AL 
                  .o+`                   ------------ 
                 `ooo/                   OS: Arch Linux x86_64 
                `+oooo:                  Host: 21BVCTO1WW ThinkPad T16 Gen 1 
               `+oooooo:                 Kernel: 6.2.12-arch1-1 
               -+oooooo+:                Uptime: 19 mins 
             `/:-:++oooo+:               Packages: 1041 (pacman) 
            `/++++/+++++++:              Shell: zsh 5.9 
           `/++++++++++++++:             Resolution: 1920x1200 
          `/+++ooooooooooooo/`           WM: i3 
         ./ooosssso++osssssso+`          Theme: Adwaita-dark [GTK2/3] 
        .oossssso-````/ossssss+`         Icons: ArchLabs-Dark [GTK2/3] 
       -osssssso.      :ssssssso.        Terminal: xfce4-terminal 
      :osssssss/        osssso+++.       Terminal Font: Monospace 12 
     /ossssssss/        +ssssooo/-       CPU: 12th Gen Intel i7-1255U (12) @ 4.700GHz 
   `/ossssso+/:-        -:/+osssso+-     GPU: Intel Alder Lake-UP3 GT2 [UHD Graphics] 
  `+sso+:-`                 `.-/+oso:    Memory: 3309MiB / 15695MiB 
 `++:.                           `-/+/
 .`                                 `/

I have seen, via my unsuccessful searches on how to fix this, references to problems with virtual box and certain kernels for 11th generation and above Intel, but just couldnt work it out.

So I thought I’d ask here if anyone else had similar problems & perhaps how they fixed them



This question seems to be asked often over at Arch. This seems to have help a few out.


Thanks @anon28865476
I had seen similar posts but not that one!

Now I see that I should add ibt=off as a kernel parameter as per:

But, I have no idea what that means :smiley:

So, I tried following the below from the post linked above

I added it to my /etc/default/grub like this:

GRUB_CMDLINE_LINUX_DEFAULT="loglevel=3 quiet ibt=off"

then run:

sudo grub-mkconfig -o /boot/grub/grub.cfg

and finally rebooted.

But the VM still didnt work and sudo nano /etc/default/grub showed me that ibt=o hadnt been added

So I simply manually added it, using nano, to insert in the “” the following on the GRUB_CMDLINE_LINUX_DEFAULT line to give:


Then (after I finally remembered to do the sudo grub-mkconfig -o /boot/grub/grub.cfg bit :roll_eyes:), the VM’s worked!

Thanks @anon28865476!

EDIT: In the spirit of ‘might help someone later’:

In i3, to get the full screen to work

for fullscreen in virtualbox make sure that in the VM options you don’t have the mini-toolbar set to show in fullscreen/seamless (go in the VM settings, ‘user interface’, remove the checkbox) at least with my virtualbox version I have to do that otherwise fullscreen does not work


Glad that you got it fixed @leigh It might help out in the future.

Props to @anon28865476 for the solution.


If you have a spare computer to play with, try QEMU/KVM.
Used Virtualbox for many years and still have one computer with, but QEMU/KVM was a game changer.