Virtualbox full screen corruption [SOLVED]

Not a Archlabs issue i’m sure, but Virtualbox doesn’t work properly in full screen mode. VB is version 6.0.4 r128164 Extension pack is installed. Earlier versions of VB worked ok.

When i hit ctrl+f my screen looks like this:

I’ve i3 Gaps. The log: https://www.dropbox.com/s/qzo3kisctjw8gve/Arcolinux-2019-02-13-12-50-45.log?dl=0

Awesome !
Did you try again the same iso with an older version of VB just after that ?
You use virtualbox-guest-modules-arch (and host) ?

It’s the same with all isos. Haven’t tried older VBs yet.

I didn’t have modules-arch installed. Tried with it, no change.

I usually install just the basic Virtualbox and linux-headers packages from the repo and the matching extension pack from the AUR and things have been ok.

The older VB packages are .run files i guess, does it require something special to run them?

Check your vb version first.
And then downgrade virtualbox:
pacman -U /var/cache/pacman/pkg/old_version_virtualbox
If it still doesn’t work there is another problem.

Ok, installed 5.2.26 from the VB website, nothings changed.

Maybe Nvidia proprietary driver or kernel thing…? I don’t know if i’m able to fix screen tearing without prop. Nvidia driver, and my system doesn’t necessarily boot with for example LTS kernel. It’s a bit complicated. :yum:

What AL release do you have @eesau .

Edit: What s your hardware also.

The latest release (from January).

EDIT: inxi -G
Graphics: Device-1: NVIDIA GK107 [GeForce GTX 650] driver: nvidia v: 415.27
Display: x11 server: X.Org 1.20.3 driver: nvidia unloaded: fbdev,modesetting,nouveau,vesa
resolution: 1920x1080~60Hz
OpenGL: renderer: GeForce GTX 650/PCIe/SSE2 v: 4.6.0 NVIDIA 415.27

Ok thx, I edited my post when you were posting I guess also.

From Terminal :
inxi -G

Maybe that link will help you in here:

1 Like

Virtualbox is not supposed to use your nvidia driver.
Now you can use vmware graphic drivers in virtualbox, maybe you can try that.
“from the vb website”
Use the repo…
What are the graphic and ram options you use before launching the machine ?

Good call in there @k43r17h . Also nvidia & Linux usually sadly don t go well together in some cases.

Edit: I always think that these are metal installs, not much vb use on my end.

1 Like

In my case I have stopped using virtualbox, now it’s vmware (it’s easy to use it for free), but sadly whonix wont work in vmware.
I think that OP has to change something in options. I have never seen such buggy graphical mess before, it’s just incredible, I’m really interested of what is happening, not enough ram, or not enough memory video, I don’t know but that is clearly something related in the vm config.

1 Like

Yep , guess that I would start back again from zero & see what it does.

Edit: Also wonder if the iso s corrupted by itself.

I don’t know about the settings, because i basically always use the same settings and no such problem has been before. I give 6GB RAM, 2 cores of my CPU and recommended amount of graphics memory or more. Other settings are at default.

And it’s the same with all isos, it’s been like that a while now.

Yes, Nvidia isn’t related to this, but yeah, if it wasn’t for the screen tearing, i would’ve ripped that Nvidia card out allready. In fact i tried that a while ago, but didn’t find a proper fix for the tearing problem with the integrated HD 4600, so… Have to look into that a bit more some day. Otherwise that Intel GPU is enough for me, i don’t play games. Bought the damn Nvidia card because it has HDMI which i needed at the time.

Bet that Intel s integrated GPU can do the job by itself with YT & stuff alike, It s what I mostly do on my end.

Think that with all Linux s updates/upgrades, loads of apps/dependencies are getting screwed up big time as of a little while now. Guess that I ve never seen this . Also on Debain/Debian inspired distros.

1 Like

This is an issue with i3 and virtualbox, set it to be floating in your i3 config and that should fix it.


For tear free video with intel create a /etc/X11/xorg.conf.d/20-intel.conf

and put the following in it

Section "Device"
  Identifier  "Intel Graphics"
  Driver      "intel"
  Option      "TearFree" "true"
EndSection

Make sure you disable compton vsync by setting it to none in ~/.config/compton.conf, also make sure to use the xrender backend (in the same file).

Ref:
https://wiki.archlinux.org/index.php/intel_graphics#Tearing

2 Likes

Hmmm, this is interesting… I did remove the Nvidia card from my machine, booted up and checked the Virtualbox issue. Didn’t expect any change, but it has changed a bit still, now the screen goes black when i hit CTRL+F. :grinning:

It seems to be known issue with i3 WM. Floating mode didn’t help for some reason. I’ll look into it tomorrow.

Btw, i don’t know why, but now there is no screen tearing. I’ll try that fix, if it comes back. Thanks.

1 Like

Ok, it was a i3 WM bug. I turned the mini toolbar off in VB settings, now everything works as expected.

EDIT: Well, it fixed the black screen issue at least. The colourful mess is still a mystery i guess.

Glad that it s fixed in there @eesau

1 Like