Virtual machine?

Hi
I want to install Win10 in a virtual machine (dont ask, I’m now experimenting with Office on Linux methods)
is Virtual Box the best for this?
I installed it but got the below error (I dont even know what a Kernel Module is …):

Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver is either not loaded or not set up correctly. Please try setting it up again by executing

'/sbin/vboxconfig'

as root.

If your system has EFI Secure Boot enabled you may also need to sign the kernel modules (vboxdrv, vboxnetflt, vboxnetadp, vboxpci) before you can load them. Please see your Linux system's documentation for more information.

where: suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT.

Tried what they said but no luck:

leigh@archlabs ~ % sudo su
[root@archlabs leigh]# /sbin/vboxconfig
bash: /sbin/vboxconfig: No such file or directory

There are some additional packages to install and configure. Read through this: Virtual Box Arch Wiki

You will be installing a Windows guest on an Arch Linux host.

Which version of Windows are you trying to install?

2 Likes

He is trying to install Win10.

I personally just dual-boot. Too much ram hogging when in VM and I got 32GB ram lol

2 Likes

You didn’t mention your hardware. If desktop, use a second drive and put Win on it. Update boot loader on the Linux setup to dual boot.

2 Likes

That’s exactly what I do for when the rare urge to play Dark Souls III hits me.

2 Likes

If it’s a lappy, and the Optical drive is removable see this:

External USB optical drives are cheep if you want both. The also sell an adapter to use the optical drive you took out of the lappy. And of your lappy has eSATA, your golden.

1 Like

Thanks all

Sorry - my post was not very explicit

I currently dual boot to Win 10 and probably will end up using Libre Office (because Softmaker doesnt have an equation editor in Linux [unless I can get round that somehow])

I’m just playing. But It might work as I have 16 GB ram which is never used and wont always be doing this.

I used to have VB with Win10 on (in Manjoro - sorry for any offence) and many others but I ran into this problem installing on AL.

It was quite cool to have the ‘seamless’ option or whatever it was called

Have been thinking of another SSD in the optical drive - but its the only DVD player we have in the house.

1 Like

Ah yes DVD, the beer coasters that contain information :smiley:

Can you purchase an external drive to do the job?

1 Like

What’s the make and model number?

1 Like

Its an ASUS X550LB

Also, what s the cup & its gpu, might help also.

1 Like

Lots of reasons to have a second drive. Put the swap partition on it, dual boot, automatic realtime backup of an important dir/partition, etc.

Reuse the slimline optical drive with a $10 cable. USB 3.0, so your good to go.

1 Like

ArchLabs_2022-07-03-45_1920x1848

1 Like

That looks great, I’ll look for a cable on Amazon.es

If I replace the optical drive with a hard disk, are there versions that eject, so its like an ‘internal/external’ drive?

I have Noggin the Nog on DVD

EDIT:
Does this cable look good?
How do I know if its 9 or 9.5 mm (is it easy to measure / correspond to actual thickness? (might be a ‘nominal’ thickness)
Also this caddy?

If it did eject, it would need to be done with the lappy off; no hot swap. But I haven’t seen one.
In your case you’ll need to split the case to install. Not hard, just a few screws.

1 Like

I am following this to try to get VBox working

I am on 5.18.8


core/linux 5.18.8.arch1-1 (174.5 MiB 175.0 MiB) (Installed)
    The Linux kernel and modules

so I installed:

community/virtualbox 6.1.34-4 (35.4 MiB 162.6 MiB) (Installed)
    Powerful x86 virtualization for enterprise as well as home use

community/virtualbox-host-modules-arch 6.1.34-20 (239.0 KiB 236.3 KiB) (Installed)

I seem to have the right modules:

leigh@archlabs ~ % cat /usr/lib/modules-load.d/virtualbox-host-modules-arch.conf
vboxdrv
vboxnetadp
vboxnetflt

I rebooted and did:

leigh@archlabs ~ % sudo modprobe vboxdrv
[sudo] password for leigh: 
leigh@archlabs ~ %

OK, now Vbox is working and I am installing win10 :smiley: :smiley: :+1: :+1:

The problem was I didn’t reboot before to load the modules - I think

2 Likes

Moderator edit for security concerns.

@leigh - pretty sure your post has been sent to Oblivion.

Good that you got your VM working.

Take this opportunity to remind users to proofread their posts for sensitive personal content before hitting the Reply button.

1 Like

Thanks
And sorry 'bout that

Not a problem.

So, back to normal service again :blush:

Woo-Hoo!
Got it all working and I have to say that the Win 10 VM in Virtualbox host on AL seems to be even faster than my dual boot Win10 instance :slight_smile: :slight_smile: :+1: :white_check_mark:

Below two carefully proofread posts :blush:, first one with seamless view mode and VM win10 and AL apps on same external monitor, second one with fullscreen VM Win10 on external monitor and AL apps on the Lappy monitor
I think the latter is easier to understand and control

3 Likes