Vim colors

I have spend more time fiddling w/ vim colors (both gui and term) than I would like to admit. Just a small tip here. If you are using jinx (nateji’s excellent color scheme) in nvim (I think that is default in AL), I found it nice to mute the main color a little with
:hi normal guifg=aquamarine4

olivedrab4 or seagreen4 are other colors that have similar feel.
You can just do this in a running nvim instance and see if you like it. I do a lot of coding in early morning hours, before sunrise, and the white is too much contrast at that time.

One more that I turn to is navajowhite3. I find 3 to be just right, 4 is too dark and 2 has too much contrast.

This helped me. Hope someone else also likes it.

–Cheers to all AL’ers, and fight on for free speech.
Je suis Charlie Hebdo. Mein hoon Mahashe Rajpal.

2 Likes

Nice tip I almost like the feel if a bit close to the green used for syntax. I have to admit my support of the light and mid contrast (day, night) variant has been very poor and I usually just use midnight one, the default is night which is more between the two but might need some touch ups. I’d be curious to see what anyone who uses it would like as defaults.

1 Like

I am using night fyi.

I should try midnight more.

I also try the following for hi normal:
lightgoldenrod3, goldenrod3, navajowhite2 and others. I stuck with the greenish variants over the creamish.

1 Like

If you use :set termguicolors then you can also use hex codes like #107040 for more control over the colour.

2 Likes

Is that necessary for neovim? Somehow I thought neovim had that inbuilt? I am trying to get a very dark green as my background …

From :h termguicolors

  				*'termguicolors'* *'tgc'*

‘termguicolors’ ‘tgc’ boolean (default off)
global
Enables 24-bit RGB color in the |TUI|. Uses “gui” |:highlight|
attributes instead of “cterm” attributes. |highlight-guifg|
Requires an ISO-8613-3 compatible terminal.

So yea even in neovim the default is notermguicolors

OK, that does explain why the hex codes were not producing their intended effect in neovim. I was trying to get a really dark green, but it would not budge. Will turn on termguicolors.