(venv) isn't showing up in shell prompt


#1

I used to issue $pipenv shell then I get the prompt like this: (venv-name) user@host [dir] $ but now I don’t see it.

How should I get it back?


#2

Hello, I do not use this shell, so I know less than zero.
See if you can find help here


#3

I’m guessing you had something installed to show this information, by default no shell does this.
You’ll need to set up your prompt to check for a virtualenv or use oh-my-zsh it comes with a plugin called virtualenv and you can just enable it…

NOTE: On Archlabs you’ll need to remove the package grml-zsh-config with pacman -Rs after installing oh-my-zsh or else the two conflict.


#4

This just explains the difference. It didn’t help. Thank you :smiley:


#5

I did as you said, and it works fine now. Thank you very much :smile:


split this topic #6

A post was split to a new topic: Bash Virtualenv