Using Qutebrowser

Here we go fellas, Qutebrowser seems a lot more popular around here lately (or it could be just me having a little bit of wishful thinking?)

Anyway, share your Qutebrowser discussions, configs and screenshots here!

1 Like

You using any 3rd party scripts?

And wasn’t there a binding for opening a new tab? Doesn’t seem to be one now.

2 Likes

I do use some third party greasemonkey scripts. I’ll pm you a link to the configs I shared with @subjunkie yesterday.

What I us to open a new tab is use shift+o or you can just use the traditional ctrl+t.

2 Likes

Much improved since I last used it.

2 Likes

Yeah it is slowly becoming a browser that more than competes with the big boys. The one thing that stops Qute from being perfect is the lack of element blocking. Once we have that I am 100% happy.

3 Likes

10 days left. :smiley:

2 Likes

Yeah, its frustrating. Soon none of the Google apps will support Qutebrowser.

Good thing Slack has it’s own desktop client.

GitHub said the same, at least on widows.

You might want to check your Qute settings, I just checked and I’m not getting those warnings? Only with Google apps.

lol, looks like google doesn t want you to use qutebrowser !

1 Like

Good thing I don’t want to use Google.

2 Likes

Interesting, DeviantArt is giving me the unsupported browser warning now. Wonder if Qute is in need of an update?

Oh, might be that @Dobbie03

Did you set the UA in the browser? I am using " [Mozilla/5.0 (Windows NT 10.0; rv:91.0) Gecko/20100101 Firefox/91.0]" and able to log in google.

1 Like

Yes, that’s all fine and I login okay there.

It’s just the out of date flag that I am seeing on a few random sites.

2022-02-19-@11-08-21-scrot

It only happened to me on Windows.

It’s much more convenient (to me) to have Slack in a browser tab. Same applies to Discord: I installed the client, but never use it.

I need to learn more about QB. For now I have no idea on how to change the user agent.

What’s your UA look like? google is pushing to use their blink engine if it detects that you’re using a chrome/chromium based browser.

Change it in your config.py.

This is what I have, I grabbed it from a random config. Has been fine up until the last few days:

config.set(
    "content.headers.user_agent",
    "Mozilla/5.0 ({os_info}) AppleWebKit/{webkit_version} (KHTML, like Gecko) {upstream_browser_key}/{upstream_browser_version} Safari/{webkit_version}",
    "https://web.whatsapp.com/",
)
config.set(
    "content.headers.user_agent",
    "Mozilla/5.0 ({os_info}) AppleWebKit/{webkit_version} (KHTML, like Gecko) {upstream_browser_key}/{upstream_browser_version} Safari/{webkit_version} Edg/{upstream_browser_version}",
    "https://accounts.google.com/*",
)
config.set(
    "content.headers.user_agent",
    "Mozilla/5.0 ({os_info}) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/99 Safari/537.36",
    "https://*.slack.com/*",
)

Also, @nwg see here:

https://www.qutebrowser.org/doc/help/settings.html#content.headers.user_agent

You’re telling the server that you’re using a chrome/chromium based browser. Are you using webkit as the back engine?