Usb flash installatinon media is not detected

After installing the AL_202011 iso using dd the bios(uefi mode and legacy) wont recognize the usb, it is not shown in the boot menu.
I also tried booting into AL using grub from the command line:

linux (hd0,gpt1)/arch/boot/x86_64/vmlinuz-linux
initrd (hd0,gpt1)/arch/boot/amd-ucode.img
initrd (hd0,gpt1)/arch/boot/intel-ucode.img
initrd (hd0,gpt1)/arch/boot/x86_64/initramfs-linux.img
boot

which resulted messagin:

:: Mounting '/dev/disk/by-label/' to /run/archiso/bootmnt'
Waiting 30 second for device /dev/disk/by-label/ ...

filesystem info:

~ lsblk -f                                                                                                                        
NAME        FSTYPE      FSVER            LABEL       UUID                                   FSAVAIL FSUSE% MOUNTPOINT
...
sdb         iso9660     Joliet Extension AL_202011   2020-11-05-05-54-34-00                                
├─sdb1      iso9660     Joliet Extension AL_202011   2020-11-05-05-54-34-00                       0   100% /run/media/bar/AL_202011
├─sdb2      vfat        FAT16            ARCHISO_EFI 4165-D4DF                                             
└─sdb3                                                                                                     

I think my bios is corrupt. It doesn’t detect USB flash media, and it cannot boot into windows which is installed by default. I can only boot into grub and then, from there, into current arch/windows.
Does someone know something about this?

Does your bios is up to date ! It happened to someone here in the forum lately.

I have updated the BIOS to make sure it is ok. Maybe something that has to do with the /EFI directory?

It s something that can be looked at, we never know sometimes.

Try the USB on another machine, or create the USB bootable media again? To be safe, sync before you eject your USB after dd.

I synced, and used etcher to make sure. It worked on another machine tho, thats why I tried booting from grub. Maybe I did something wrong…

Sounds like a bios issue now. What’s your machine? If it’s a pretty new one, make sure secure boot is disabled. If it’s a mac, use “option + c” to boot from a USB device.

Its a thinkpad e495, and secure boot is disabled. Thanks.
Any more info which might help?

Is this your first time trying to install Linux on this machine? I have a Legion 5i. It also took me some time to get over the bios settings.

The third time. I have dual booted windows with two more linuxes(one of them which I can’t boot into). I current installation is located in a new sata connected ssd.
I must have fucked up the installation with the last one somehow.
The usb flash device is not shown in the boot priority order, but is detected by in the storage bios’s info section.

I don’t have the Lenovo device here, so I can not check exactly in the bios setting. I remember I went to Windows and then bios from the shutdown option. In the bios, there’s a setting which says something like “use USB device”. From there, you can boot directly from your USB. I will check the settings on my device when I have access to it.

I did not find such option.

I have an E485, go to Security → Boot in the firmware (“BIOS”) setup menu, that has options to disable booting from USB devices.

1 Like

Looks like the solution.

On my Legion, from Windows login window, hold “shift” key and click “Restart” option. The device then goes into a window. The 2nd option, "Use a device (USB, …) will allow the device to boot directly from USB devices.


Maybe it is not the same bios? I could not find it.

@chroot
The USB device did not show there, only: “Grub”, and “Boot”,
which are the other grub installations.

Here’s what I was talking about. I have a different device though.

1

Sorry, my mistake — it should be under Startup → Boot

@Head_on_a_Stick It didn’t show there either.
Thats why I wanted to boot from grub, if anyone knows howto …

I finally managed to chain into the grub installed into the usb device and boot the iso from there. Thank you all :slight_smile: