Upgrade your polkit if you haven't

You should have at least version 01.120-4. See CVE-2021-4034

4 Likes

Thx for sharing @chroot

A good thing to know !

Thanks for sharing, that’s the current version in Arch repos at the moment.

Got the update on the 25th. :+1:

2 Likes

Great explanation by DJ Ware on the subject and more

3 Likes
$ LANG=C pacman -Qi polkit
Name            : polkit
Version         : 0.120-4
Description     : Application development toolkit for controlling system-wide
                  privileges
Architecture    : x86_64
URL             : https://www.freedesktop.org/wiki/Software/polkit/
Licenses        : LGPL
Groups          : None
Provides        : None
Depends On      : glib2  pam  expat  systemd  js78
Optional Deps   : None
Required By     : colord  gufw  polkit-gnome  rtkit  udisks2
Optional For    : gparted  networkmanager  systemd
Conflicts With  : None
Replaces        : None
Installed Size  : 1906.07 KiB
Packager        : Jan Alexander Steffens (heftig) <heftig@archlinux.org>
Build Date      : Tue Jan 25 17:04:02 2022
Install Date    : Sun Jan 30 10:13:24 2022
Install Reason  : Installed as a dependency for another package
Install Script  : No
Validated By    : Signature
2 Likes