Updated fails because of conflicting packages

#1

I haven’t updated my install of ArchLabs since last year. I ran yay, but ran into a couple packages that were corrupt

Total Download Size:      0.67 MiB
Total Installed Size:  5965.10 MiB
Net Upgrade Size:       158.33 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
 pcsclite-1.8.25-1-x86_64                                               92.7 KiB   965K/s 00:00 [--------------------------------------------------------] 100%
 qpdfview-0.4.18beta1-1-x86_64                                         591.4 KiB  4.81M/s 00:00 [--------------------------------------------------------] 100%
(688/688) checking keys in keyring                                                              [--------------------------------------------------------] 100%
(688/688) checking package integrity                                                            [--------------------------------------------------------] 100%
error: pcsclite: signature from "Alad Wenter <alad@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/pcsclite-1.8.25-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] 
error: qpdfview: signature from "Alad Wenter <alad@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/qpdfview-0.4.18beta1-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] 
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.
Error installing repo packages

I tried this solution, but it didn’t work.

Any advice?

0 Likes

#2

Can you uninstall them, then run your update and reinstall after?

0 Likes

#3

Alad’s key was re-enabled quite a while ago:

https://bbs.archlinux.org/viewtopic.php?id=241313

Follow Eli’s advice in the linked thread, that should do it.

1 Like

#4

I was able to update the keys. Unfortunately, my laptop randomly shutdown and when I rebooted, it could not find the drive

0 Likes

#5

You may need to arch-chroot into the system and update again pacman -Syu and run mkinitcpio -p linux

But take a look at this link before you do, the author had similar error to you.

https://www.soimort.org/notes/170407/

0 Likes

#6

If you have a separate boot partition then make sure that is mounted before running arch-chroot to enter the system.

For example, if the main system is on /dev/sda1 and /boot is on /dev/sda2 then use

mount /dev/sda1 /mnt
mount /dev/sda2 /mnt/boot
arch-chroot /mnt

Then just re-installing the kernel package should fix it:

pacman -Syu linux

If you prefer to perform the repair from a graphical desktop then use a Debian buster live ISO image[1] and

apt update && apt install arch-install-scripts

to get access to the arch-chroot command.

1 Like

#7

I’ll give these suggestions a try, but I’m inclined to Nuke and Pave because I don’t really have any files on this system.

0 Likes

#8

I used the default option when I installed it 9+ months ago.

0 Likes

#9

Hmm, not sure what the defaults are tbh :blush:

Perhaps mount the main partition first and then try

find /mnt -name vmlinuz-linux 

If it can’t find the kernel image then you must have a separate /boot partition.

Hopefully somebody who actually knows what the default option is will chime in and simplify things for you.

0 Likes

#10

Like I said, I think I’ll just nuke and pave. That would be the quickest way to have an up-to-date system. There were no important or un-backedup files

1 Like