Update systemd 246

Hi,

i have this update errors :

 ┌ ~
└> % LC_ALL=C  sudo pacman -S systemd                                   1:21:03
[sudo] password for don: 
warning: systemd-246.1-1 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Packages (1) systemd-246.1-1

Total Installed Size:  23.46 MiB
Net Upgrade Size:       0.00 MiB

:: Proceed with installation? [Y/n] y
(1/1) checking keys in keyring                     [----------------------] 100%
(1/1) checking package integrity                   [----------------------] 100%
(1/1) loading package files                        [----------------------] 100%
(1/1) checking for file conflicts                  [----------------------] 100%
(1/1) checking available disk space                [----------------------] 100%
:: Processing package changes...
(1/1) reinstalling systemd                         [----------------------] 100%
:: Running post-transaction hooks...
( 1/11) Updating systemd-boot
Copied "/usr/lib/systemd/boot/efi/systemd-bootx64.efi" to "/boot/EFI/systemd/systemd-bootx64.efi".
Copied "/usr/lib/systemd/boot/efi/systemd-bootx64.efi" to "/boot/EFI/BOOT/BOOTX64.EFI".
( 2/11) Creating system user accounts...
( 3/11) Updating journal message catalog...
( 4/11) Reloading system manager configuration...
( 5/11) Updating udev hardware database...
( 6/11) Applying kernel sysctl settings...
Not setting net/ipv4/conf/all/rp_filter (explicit setting exists).
Not setting net/ipv4/conf/default/rp_filter (explicit setting exists).
Not setting net/ipv4/conf/all/accept_source_route (explicit setting exists).
Not setting net/ipv4/conf/default/accept_source_route (explicit setting exists).
Not setting net/ipv4/conf/all/promote_secondaries (explicit setting exists).
Not setting net/ipv4/conf/default/promote_secondaries (explicit setting exists).
( 7/11) Creating temporary files...
( 8/11) Reloading device manager configuration...
( 9/11) Arming ConditionNeedsUpdate...
(10/11) Updating linux initcpios...
==> Building image from preset: /etc/mkinitcpio.d/linux-zen.preset: 'default'
  -> -k /boot/vmlinuz-linux-zen -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-zen.img

as I solve, I also removed netctl but nothing to do does not solve, when I update systemd it always has this error.
with older version of systemd i don’t have this:
Not setting
Here they talk about the problem but I understand little about it.

https://bugs.archlinux.org/task/67530
Thank for help

Those messages are nothing to worry about unless you actually use netctl.

And when posting errors please prepend the command with LC_ALL=C to make it speak English, like this:

LC_ALL=C pacman -Syu

For the .pacnew message see https://wiki.archlinux.org/index.php/Pacman/Pacnew_and_Pacsave

Ah okay.
Fixed the tag code in English
thank @Head_on_a_Stick

1 Like