Update of libxft-bgra-git failed on 2 computers

Hello!

My vacation is coming up and I am going to spend more time on “fiddling” and “fiddling”.

I use libxfg-bgra-git for colour-emojis and update gave me the following message. (on 2 of my laptops)

libtool: Version mismatch error.  This is libtool 2.4.6, but the
libtool: definition of this LT_INIT comes from libtool 2.4.7-dirty.
libtool: You should recreate aclocal.m4 with macros from libtool 2.4.6
libtool: and run autoconf again.

Itś a bit tricky to uninstall. Lots of app dependent on libxft.

Anyone with similar dealings and/or hints in right direction?

womp

Hello again!

I was able to replace libxft-bgra-git with libxft-bgra. I am not able to reinstall libxft-bgra-git. Get the same libtool message.

Maybe I should just wait a couple of days and it will be solved?

womp

Report the errors to libxft-bgra-git’s AUR page.

Ok thanks for the tip!
I will try. Have never done that before. I have very few dealings with the Arch Community directly. Itś never pleasen´t to be treated like an idiot.

womp

Try this first,

#aclocal && libtoolize --force && autoreconf

then upgrade.

1 Like

Hi! Thanks for looking into this!!

When I run "aclocal && libtoolize --force && autoreconf " I get:
“aclocal: error: ‘configure.ac’ is required”.

I tried to trace but only came to “autoconf-macros” but “configure.ac” still can´t be found.

womp

Still not solved and I have gone back to plain libxft. Have posted i AUR and got a very nice answer but no solution yet.

womp

Oh, bet that one needs to be patient.

1 Like

See if this helps.

1 Like

Thanks so very much for this link!!!
Reading the whole page a couple of times made me understand!
I solved it!

womp

1 Like

Glad that you got it fixed @womp . Props @chroot for the link;

Please mark it as solved @womp as it can be of some help for other members later on.

3 Likes