Update error /usr/lib/libmozjs-52.so.0

for those who had this error, just give the following command:
sudo rm /usr/lib/libmozjs-52.so.0
and new update
sudo pacman -Syu

1 Like

Nice, just came across this conflict myself. Cheers for the share.

2 Likes

@ector thanks, was trying to find solution myself. The last update got me. I keep getting black screen as well. I think the last nvidia update was the culprit.

1 Like

I saw it posted at the the Arch forums too.

Well I’m also getting the infamous black screen as well as loosing access to windows. I really got hammered. Tried quiet and the other remedies, but no dice. Not even a cursor! Makes me want to curse! @#!$%

1 Like

Weird update went well as normal over here.

1 Like

I think when my nvidia driver was updated, that was when it occurred. Before that, no issue.

1 Like

Hmmm interesting. Do you not use the open source drivers?

1 Like

I use the nvidia driver nvidia-340xcx which is a legacy driver. I saw it updating before I logged out then tried to log in. That’s when I ran into this issue. I tied reinstalling on a diferrent partition on my second drive. Same issue.

Nvidia has never worked out well for me hence me sticking with ATI

1 Like

well it was doing just fine. But I am not sure what occurred or why they updated the driver. I’m trying to access the installed AL through my live drive to see if I can figure out what was the issue.

So far I’m on the white list … since the first installation of the AL (last year) I had no problems with anything!
Except the ones I caused myself.:joy::rofl:

1 Like

Be careful, as soon as you say you have no problems, then a catastrophic event will happen! Lol. But, I can’t seem to the solution to that partition. Any ideas?:crazy_face::rage::angry:

1 Like

Unfortunately not, this laptop that I use is very old (2009) and so it uses basic drivers, I think this is one of the positive factors about errors of new drivers… :thinking:

From yesterday to today were 27 updates, I let aculumar a little, always in this range, 25 … 30 …

I always take a screen :rofl: to remember and help in the search in the list via the terminal. (then erase)

Soon someone will help you with some solution … sorry. :pensive:

1 Like

I use nouveau drivers, so I could not tell you, but I would try to configure nvidia again

Same thing is happening with /etc/skel/.vimrc . I’ve got both issues in two different update sessions and solved the same way.
Open source drives in my PC, for the statistics.

Apologies for the update issues regarding package changes.

The javascript lib file libmozjs-52.so.0 wasnt my doing but there may be some in /etc/skel/

Well I got this message from Arch announce. Apparently, everyone is affected.

Message: 1
Date: Fri, 04 May 2018 20:27:33 -0000
From: “Arch Linux: Recent news updates: Jan Steffens”
arch-announce@archlinux.org
To: arch-announce@archlinux.org
Subject: [arch-announce] js52 52.7.3-2 upgrade requires intervention
Message-ID: 20180504202733.805.94417@apollo
Content-Type: text/plain; charset=“utf-8”

Due to the SONAME of /usr/lib/libmozjs-52.so not matching its file name, ldconfig created an untracked file /usr/lib/libmozjs-52.so.0. This is now fixed and both files are present in the package.

1 Like

Nice find man, I knew something odd happened

2 Likes