ArchLabs Linux

Update error: unable to satisfy dependency 'nvidia-utils=430.40'

Has anyone experienced an issue like this today?

$ sudo pacman -Syu
[sudo] password for piotr: 
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'nvidia-utils=430.40' required by nvidia

I’ve got nvidia-utils-430.40-2 and lib32-nvidia-utils-430.40-1 installed ATM.

Pending updates:

$ checkupdates
android-tools 29.0.2-1 -> 29.0.2-2
bbswitch 0.8-246 -> 0.8-247
cups-filters 1.25.3-1 -> 1.25.4-1
device-mapper 2.02.185-1 -> 2.02.186-1
gawk 4.2.1-2 -> 5.0.1-1
linux 5.2.10.arch1-1 -> 5.2.11.arch1-1
linux-headers 5.2.10.arch1-1 -> 5.2.11.arch1-1
lvm2 2.02.185-1 -> 2.02.186-1
nemo 4.2.2-1 -> 4.2.3-1
nvidia 430.40-6 -> 430.40-7
nvidia-utils 430.40-2 -> 435.21-1
opencl-nvidia 430.40-2 -> 435.21-1
ruby 2.6.3-1 -> 2.6.4-1
unrar 1:5.7.5-1 -> 1:5.8.1-1
1 Like

Yes I fixed it once earlier by by installing nvidia-dkms separately, first, in my case. However they seem to be on a roll today, just got 435.21 via regular sudo pacman -Syu with no issues.

Weird, wonder if you clear the cache & try again if it will do the same.

Yes: I took a long nap, and the issue seems to have auto-resolved in the meantime.

1 Like

Nothing or nearly nothing beats a nap.

2 Likes