Unrecognized archive format

Hi guys, new AL user here. Just installed 2020.11.04 on my laptop today. Everything went smoothly. Really like the installer. Fast & straightforward. Thanks for the great work!

After the installation & full system upgrade, this issue came up.

 cal@arch:/var/lib/pacman/sync$ pacman -F iwconfig
core/wireless_tools 30.pre9-3 [installed]
    usr/bin/iwconfig
extra/bash-completion 2.11-1 [installed]
    usr/share/bash-completion/completions/iwconfig
error: could not open file /var/lib/pacman/sync/archlabs_repo.files: Unrecognized archive format

 cal@arch :/var/lib/pacman/sync $cat archlabs_repo.files 
archlabs_repo.files.tar.gz% 

Have tried to remove all files from /var/lib/pacman/sync and then re-sync from the repos. Didn’t work.

Hello @chroot and welcome to the forum.

That file is just a symlink to the tarball as seen when you cat it out. I’ve tried removing the link and just renaming the .tar.gz to .files, seems to have fixed it here but let me know if it’s still an issue (need to force a resync with -Syyu and -Fyy).

Works fine now. Thank you, @natemaia.

1 Like