Unable to install fully complete with options on Hyper-V (Windows 10 2004)


I’ve been trying the past few days to get a virtual machine running to test out ArchLabs before committing to using it on my XPS 13 (9343). The reason being is that I also can’t seem to get the live session to run as it errors out as well (I haven’t gotten the errors for that one written down and figured why not go for a VM first to fully get used to the OS.)

My host is a Ryzen 7 2700x with 32GB RAM and NVMe storage. It runs well so a VM running on it should be OK.

The VM setup is a Generation 2 VM (UEFI) setup with 4096MB RAM and 32GB Storage for a small test VM. I get through most of the installer, but run into some odd issues here and there that don’t seem to make sense.

I’ve ensured that secure boot is off so I can get the installer running OK.

  1. I first choose Auto-Partitioning to get a quick setup going. This works great and no errors.
  2. I skip LUKS and LVM
  3. Mount Partitions works and mounts
  4. I make a swapfile of 3937M and it’s successful
  5. I choose Pacstrap
  6. I chose systemd-uefi this time but have chosen grub in the past
  7. usrename created
  8. Bash is chose
  9. Archlabs is the hostname
  10. en_CA is the locale
  11. America/Toronto is the date/time region
  12. Linux-Zen is the kernel
  13. Openbox is chosen with lightdm

That’s how I start the installation and you can see in the picture what I have chosen to install.

Here is the first error

I then try continue it’s fixed and it runs forward. It then runs into another error.

Now this time I tried handle normally which spits to a shell, but when I run it otherwise, it completes to the end with usually another error and then I reboot. The error usually is still to do with lightdm it appears.

After a reboot, I get to a login (no lightdm which makes sense) and I can’t do much at all. I’m sure I could start and rebuild from there as it’s down to a pretty basic Arch install, but I want to trial the ArchLabs experience.

Hopefully the above information helps and we can get to a full install. Maybe I’m missing something basic. I’ve been out of the Linux game for a bit but want to jump right back in again.


I thought I had searched enough but it’s late and I didn’t.

Found this in the forums.

Going to try it in the morning.

So taking from the other post to answer here as well, it appears that the installer did require an update. In order to do so, as soon as you get to the page that tells you next steps you’ll want to run the following:

pacman -S archlabs-installer

What this does is updates the installer to the latest version before continuing. It does change the name however so you’ll need to run


in order to run the true new installer. This will get you a proper installation.

A big thanks goes to 3O0QUI1O on the other post about this.

after updating the installer , did you succeed to install the AL properly ?

That’s correct, once the installer was updated, I was able to fully install AL without any issues.

1 Like

I guess there may be one more addition. You may need to do

pacman -Sy

To update the packages first. Then update the installer. Then run it.

You can do them both at once

pacman -Sy archlabs-installer

Please mark the post that solves the issue in the future, cheers.

Thanks for that! Always good to have a 2-in-1.

I was meaning too once I was super sure it was all working correctly! Will do moving forward so others quickly resolve!