Unable to Boot in VB, VMWare, or HyperV

Hi all,
I just tried to boot up the latest iso and it stops after the message:
isolinux: Found something at drive = …
isolinux: Looks reasonable, continuing…

Then… nothing. I tried varying combinations of ram 4GiB-8GiB, cores: 1-6 and allocated drive space 24GiB to 70GiB in three different environments: VMWare Player 16, Virtual Box (Latest) and HyperV (tried both option 1 legacy and 2).

Has anyone ever been stuck at this point?

BTW the only boot options that come up for me are as follows on all three platforms:
Boot existing OS
Run Memtest86+ (RAM test)
Hardware Information(HDT)
Reboot
Power Off

The “Boot existing OS” doesn’t make sense to me but for lack of anything else it’s the only one I tried using to boot.

https://wiki.archlinux.org/title/VirtualBox

https://wiki.archlinux.org/title/VMware

3 Likes

Thanks judd, appreciate the links, there is a lot of useful info there for setting up vmware on linux. I am however running vmware, vbox and hyperv on windows and attempting to boot the iso in a VM, the iso gets recognized ok and shows grub boot options as per above, so unfortunately the links you have posted are not relevant and do not provide an answer to my question:
-why is there no boot option into live environment?

This issue/error has happened before.

Never resolved.

It should be there.

Maybe try downloading and burning he iso again.

1 Like

And welcome to the forum.

1 Like

I can confirm this behavior in a VM.
Here in QEMU it looks exactly like this:



None of the links provided are helpful.
I was of the opinion to be somehow too stupid, because after all my last installation of archlinux was nearly 8 years ago and it is still running today. Since then I haven’t bothered with the installation process of this OS.

So, how do I get into a terminal to type ‘installer’ and start the live process with dk?

Background:
there are three partitions in qemu
sda1 - swap
sda2 - hatchery
sda3 - siduction NOX

siduction should be replaced with archlabs

Does it only do that in a VM?

Which iso are you using; current kernel or lts?

1 Like

Just downloaded the ISO ( not lts ) and installed it into QEMU/KVM without having to do anything special. So not much help here.

2 Likes

What is the second screenshot that gives you that command line? Is that what you get if you press 'Tab"?

1 Like

It is the LTS version.
The ISO is on a different HDD.
I load ISO’s to install in QEMU with the following command:

$ qemu-system-x86_64 -enable-kvm -m 2048 -smp 2 -vga std -cdrom /media/Distris/archlabs/archlabs-lts-2023.01.20-x86_64.iso -name AL -boot d -drive file=/home/unklarer/virtu/platte.img

@PackRat, right.
The second image comes after TAB; further ‘help options’ to boot; finally it does nothing or starts the existing OS.

Edit:
Of course, I also consulted my old Arch installation files. Thereby I noticed:

Quote Martin-MS
Syslinux cannot directly boot systems from a disk other than the one it is installed on.

Is this still the case?

I tried the latest iso in virtualbox 7.0.6-1. At beginning, it stuck in udev hooks. After several changes in machine settings (enable/disable 3d acceleration, enable/disable efi, etc), it suddenly boot. I guess it’s related to the VirtualBox drivers. Try to check the vb logs to see what is going wrong and play with the settings.

1 Like

In VB I found you need to leave the display and graphic controller as is until the install is installed.
Then fine tune it after the install.

3 Likes

I can reproduce this error with the LTS iso on a legacy BIOS system.

Can you try installing with the standard iso, or is the lts kernel required for your system?

2 Likes

Are you using the LTS kernel iso?
If so, can you attempt an install with the standard iso?

2 Likes

Standard or LTS kernel?

1 Like

archlabs-2023.01.20-x86_64.iso

2 Likes

am now also with this kernel and
need help to overcome this hurdle

I have ‘paused’ the installation (Ctrl+z)

Continue with <Continue>

2 Likes

ok @judd, he just led me behind the light. :grin:

The VM starts with archlabs and he has hatchery in the menu too.
Everything is fine.
First of all thanks, except for the above ‘error’ the installation went without problems.

2 Likes