UEFI dualboot with grub2 and Windows 10

Hi girls and guys. I am searching for a solution the last two days but can not find the right solition.

I use Fedora 27 in Dual Boot with Windows 10 on my Notebook. I want to replace Fedora with ArchLabs but in my lab I can not but into Windows after installing archlabs on the last partition.

If i could I would only use archlabs, but I need Windows for my daily work as Windows Admin.

Is there a handy tool which makes it posaunte to read Windows Boot record to grub?

Tried grub-mkconfig, efibootmgr and os-prober but can not get the entry.

And hint is welcome. Thank you!

I had a month ago after updating my Ubuntu 16.04 LTS the problem, that only windows started. I used Supergrub/ which helped to restore or have a look here: Booting straight to Win10

Please post the full output of:

parted --list
efibootmgr -v

Hi @Head_on_a_Stick

here is the parted --list and the efibootmgr -voutput. Please notice, this is the output of my lab for dual booting in a virtual env.

Thanks for helping!

PARTED START

benjamin@archlabs ~ % sudo parted --list
Modell: Msft Virtual Disk (scsi)
Festplatte /dev/sda: 136GB
Sektorgröße (logisch/physisch): 512B/4096B
Partitionstabelle: gpt
Disk-Flags:

Nummer Anfang Ende Größe Dateisystem Name Flags
1 1049kB 473MB 472MB ntfs Basic data partition versteckt, diag
2 473MB 578MB 105MB fat32 EFI system partition boot, esp
3 578MB 595MB 16,8MB Microsoft reserved partition msftres
4 595MB 115GB 114GB ntfs Basic data partition msftdata
5 115GB 136GB 21,5GB ext4 archlabs

Warnung: /dev/sr0 kann nicht zum Schreiben geöffnet werden (Das Dateisystem ist
nur lesbar). /dev/sr0 wurde nur lesbar geöffnet.
Modell: Msft Virtual DVD-ROM (scsi)
Festplatte /dev/sr0: 964MB
Sektorgröße (logisch/physisch): 2048B/2048B
Partitionstabelle: msdos
Disk-Flags:

Nummer Anfang Ende Größe Typ Dateisystem Flags
2 336kB 269MB 268MB primary esp

PARTED END

EFIBOOTMGR START

BootCurrent: 0003
Timeout: 2 seconds
BootOrder: 0003,0006,0005,0004
Boot0000* EFI Network AcpiEx(VMBus,)/VenHw(9b17e5a2-0891-42dd-b653-80b5c22809ba,635161f83edfc546913ff2d2f965ed0e47962a9a241504469418193e46904d0b)/MAC(000000000000,0)
Boot0001* EFI SCSI Device AcpiEx(VMBus,)/VenHw(9b17e5a2-0891-42dd-b653-80b5c22809ba,d96361baa104294db60572e2ffb1dc7f64238230a83a104d99b15d816fb43725)/SCSI(0,0)
Boot0002* EFI SCSI Device AcpiEx(VMBus,)/VenHw(9b17e5a2-0891-42dd-b653-80b5c22809ba,d96361baa104294db60572e2ffb1dc7f64238230a83a104d99b15d816fb43725)/SCSI(0,1)
Boot0003* archlabs HD(2,GPT,792fa406-e353-456d-bb7e-fcaf095a6c76,0xe1800,0x32000)/File(\EFI\archlabs\grubx64.efi)
Boot0004* Windows Boot Manager HD(2,GPT,792fa406-e353-456d-bb7e-fcaf095a6c76,0xe1800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS…x…B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}…1…
Boot0005* grub HD(2,GPT,792fa406-e353-456d-bb7e-fcaf095a6c76,0xe1800,0x32000)/File(\EFI\grub\grubx64.efi)
Boot0006* rEFInd Boot Manager HD(2,GPT,792fa406-e353-456d-bb7e-fcaf095a6c76,0xe1800,0x32000)/File(\EFI\refind\refind_x64.efi)

EFIBOOTMGR END

@semo thank you! I will test this as soon as possible

Does not work in a first try but I will test this again later with a fresh installed windows 10 and archlabs in my lab environment.

1 Like

OK, so your system seems to be booting from the ArchLabs NVRAM entry.

Have you tried grub-mkconfig -o /boot/grub/grub.cfg (as root)?

If that doesn’t fix things then we need to see if the Windows files are still on the EFI system partition:

mount /dev/sda2 /mnt
ls /mnt/EFI

Is there a Microsoft folder listed in the output?

grub-mkconfig -o /boot/grub/grub.cfg does not fix it. Tried it with manual editing /etc/grub.d/40_custom and getting right values with grub-probe but I does not get the solution -.-

There is a Microsoft folder, but I found out that there is a difference between my lab env and my physical machine.

In the lab env there is EFI/Microsoft/Boot/BCD
on my physical machine there is EFI/Microsoft/Boot/bootmgfw.efi

physical and lab env are both installed in UEFI without secure boot …

I do not understand what you mean by “lab env”, can you please explain more?

$ESP/EFI/Microsoft/Boot/bootmgfw.efi is needed by Windows to boot and if it is not present then GRUB will not generate a Windows boot entry.

You should post the actual configuration file that you tried so that we can spot if you have made any mistakes :wink:

I do not understand what you mean by “lab env”, can you please explain more?

I have installed Windows 10 and ArchLabs in an Hyper-V VM to test the DualBoot solution, because I can not risk to kill my Windows System which is needed daily for managing customer systems.

I just started to reinstall the VM to check if one of my steps replaced the bootmgfw.efi file. So if I come again to the point to build a crappy 40_custom I will let you know :smiley:

@Head_on_a_Stick when I install ArchLabs I choose /dev/sda to install bootloader. Is this the correct way?
My windows EFI partition is /dev/sda2

I’m sorry but I have absolutely no idea — I’ve never tried the ArchLabs installer so I don’t know for sure what the “correct” choice is.

Please await the advice of somebody who knows better than me, I wouldn’t want to guess and offer inadvertent bad advice.

@Head_on_a_Stick I am sorry to inform you, that you will not be able to spot over my mistakes :smiley: after reinstalling my VM there was the missing bootmgfw.efi file in my efi partition and running grub-mkconfig -o /boot/grub/grub.cfg added the windows boot loader to grub.

so my problem is solved and next I will do a fullbackup of my physical machine and install ArchLabs next to windos 10 there :wink: fingers crossed that all possible issues are tested and fixed :crossed_fingers:

thanks you for your help :slight_smile:

One time hitting enter to fast and reformated efi partition :see_no_evil: now I have to recreate Windows efi entry or recover backup. Will try to recrete the efi entry first :-/

Restoring the EFI/Microsoft folder from your backup to the EFI system partition will get Windows booting again.

1 Like

Hi @k1ngf15h3r may I ask which AL iso are you using? Because for what ever reason any iso prior to archlabs-2018-03 seems to have trouble cohabitating with windows. Then you may want to partition your drive and give your second partition a drive letter and make it look like it is a second drive.

@sevenday4 in my virtual machine I used the 2018-02 iso. But on my physical machine I used the 2018-03 iso. Maybe this was my mistake because the 2018-02 installer did not format my efi partition. The 2018-03 installer did :wink:

@Head_on_a_Stick oh good idea thank you

Yes @Head_on_a_Stick idea will work wonderfully. Whatever you do, don’t lose that copy of the efi files until we get a handle on this. Yes , 2018-03 will reformat your efi partiton if you tell it to do so. So when you reinstall AL again DO NOT reformat the efi partiton but say no.

I noticed this in the moment my finger released the enter key :see_no_evil: will fix it tomorrow when i had sleeped and a fresh coffee in my hand :wink: