Two questions: LightDM login and ZSH prompt

Hello everyone,

So I’ve reinstalled recent AL release (reformated / and kept /home partition). I have 2 issues

  1. LightDM logs me into something that looks like my account (EDIT: i use i3-gaps) - but it doesn’t load keybindings and stuff. I need to switch TTY, relog from terminal and startx, than it goes to normal. What is happening and how can i fix this?

  2. I have created custom .zshrc with .antigen as a plugin manager. It works on the other machine i have, and works on the current one. But somehow prompt (subnixr/minimal) is not the same. Is there a config that overrides my current dotfile?

And while we are still here: how can i startx from within tmux?

Can you clarify. Are the openbox key bindings not working (i.e mod+t should launch a terminal), or are the zsh aliases not working when you log in with lightdm?

i use i3-gaps + polybar.

So i see the polybar and none of the i3 keybindings are working. Ans i have no use for the mouse in an empty screen.

After reloging through TTY the problem disappears

i do not use i3 but maybe it can help you

https://wiki.archlinux.org/index.php/i3

Might be that LightDM is broken on that install. Which greeter are you using? Maybe switch to the lightdm-gtk-greeter if you’re using something different.

I’ve had trouble with LightDm in the past; actually using Lxdm with ArchLabs now.

The only way I know how to do that is to detach from the session to startx, then attach when you log out (you can also attach to the tmux session from a terminal within X).

basic guide for tmux

I know that works, but I’m not a tmux power user by any stretch of the imagination so there may be a more elegant method.

@onoma for the lightdm issue, open /etc/lightdm/lightdm.conf and change the line containing user-session = and auto login-session = make sure they are uncommented and add i3 after each =


For your zsh question, if you are having issues with your prompt try removing the package grml-zsh-config using pacman - Rns then open/reload a terminal, do you still have the issue?


For the tmux question, you seem to be asking different questions (running startx but using a display manager?).

Do you want tmux to just be running when you start any terminal?

What is the purpose/benefit of starting an xserver from within a tmux session?

Ignoring all of that, have you tried

# login, then run tmux
tmux

# once tmux is loaded run
startx

# ??? 

# profit
1 Like

Thank you!

  1. Lightdm.conf already has i3 after = in the uncommented lines you’ve mentioned.
  2. Removing grml-zsh-config - worked like a charm. Thank you, i’ve forgotten about this package
  3. startx from tmux was an issue when i had tmux autostart script on .zshrc. Which appeared in TTY. Now I’ve removed the autostart script.

Well one down at least, let’s deal with the lightdm issue, you are still having it correct?

Could you post your lightdm.conf please?

Also check if the override directory for the getty service exists and isn’t empty
/etc/systemd/system/getty.....service.d

For a tmux auto launch script you can check if the shell is a login shell before launching tmux.

In bash and zsh the variable SHLVL is the number of nested shells currently running, when on the desktop this will be 2 or greater, a login shell is the first shell so it will have SHLVL 1.

Below is a rough example

if (( SHLVL > 1 )); then
    # tmux launch code.... 
fi

Or using [[]]

if [[ $SHLVL -gt 1 ]] ; then
    # tmux launch code.... 
fi