Two bash in top after logout

#1

I have this problem when I log out, and I return to the session, in practice in top I appear two bash see photo.
And the temperature starts to rise, it happens to you too.
every session exit reappears a bash in top, in the picture I have three because I went out two more times don’t remember well.

!

below how top appears after a normal startup, the problem arises when I logout.

!

#2

What is your system environment ? Desktop, window manager etc…

#3

Polybar,thunar and openbox.

#4

what does your bash_logout file look like?

Also i see from your top screen you have multiple instances of kworker, what is that about?

#5
#
# ~/.bash_logout
#

for the kworker boh

#6

ok what about the .bash_profile and the .bashrc

make sure you mask any private info if you have it in those files.

#7

For the kworker Completely normal.

https://bbs.archlinux.org/viewtopic.php?id=141043

#8

.profile

#
# ~/.bash_profile
#

[[ -f ~/.bashrc ]] && . ~/.bashrc

.bashrc

# If not running interactively, don't do anything
[[ $- != *i* ]] && return

export HISTCONTROL=ignoreboth:erasedups

PS1='[\u@\h \W]\$ '

#list
alias ls='ls --color=auto'
alias la='ls -a'
alias ll='ls -la'
alias l='ls'

alias merge="xrdb -merge ~/.Xresources"
alias pmsyu="sudo pacman -Syu --color=auto"
alias pacman='sudo pacman --color auto'
alias update='sudo pacman -Syu'
alias upmirrors='sudo reflector --score 100 --fastest 25 --sort rate --save /etc/pacman.d/mirrorlist --verbose'

#aggiunti da me
alias scrotpng='scrot -q 100 -c -d 5 ~/pictures/scrot-shot-%B_%e_%s.png'
alias scrotjpg='scrot -q 100 -c -d 5 ~/pictures/scrot-shot-%a_%e_%s.jpg'
alias ufont='fc-cache -f -v'
alias pacup='pacup.rb && sudo pacman -Suy'
alias nc='ncmpcpp'

alias weather="wget wttr.in 2>/dev/null -O - | grep -v 'New feature*\|Follow'"
alias today='wget wttr.in/?0Q 2>/dev/null -O -'





alias asciize='img2txt -W "$( tput cols )" -f utf8 -d random'
#asciize someimage.png # example

# youtubve-dl
alias ypa="youtube-dl  --write-auto-sub --ignore-errors --no-overwrites --embed-subs --download-archive=downloaded.txt \
    -o '%(playlist)s/%(title)s.%(ext)s'"
alias yv="youtube-dl  --write-auto-sub --ignore-errors --no-overwrites --embed-subs -f 22 -o  '%(title)s.%(ext)s'"


shopt -s autocd # change to named directory
shopt -s cdspell # autocorrects cd misspellings
shopt -s cmdhist # save multi-line commands in history as single line
shopt -s histappend # do not overwrite history
shopt -s expand_aliases # expand aliases

neofetch
EDITOR=nano

export PATH="/usr/lib/ccache/bin/:$PATH"
export MAKEFLAGS="-j5 -l8"

#diff -Naur <(curl -s http://wttr.in/london ) <(curl -s http://wttr.in/seriate )
#diff -Naur <(curl -s http://wttr.in/london ) <(curl -s http://wttr.in/new-york )

PATH="/home/don/perl5/bin${PATH:+:${PATH}}"; export PATH;
PERL5LIB="/home/don/perl5/lib/perl5${PERL5LIB:+:${PERL5LIB}}"; export PERL5LIB;
PERL_LOCAL_LIB_ROOT="/home/don/perl5${PERL_LOCAL_LIB_ROOT:+:${PERL_LOCAL_LIB_ROOT}}"; export PERL_LOCAL_LIB_ROOT;
PERL_MB_OPT="--install_base \"/home/don/perl5\""; export PERL_MB_OPT;
PERL_MM_OPT="INSTALL_BASE=/home/don/perl5"; export PERL_MM_OPT;

if [ -e /usr/share/terminfo/x/xterm-256color ] && [ "$COLORTERM" == "xfce4-terminal" ]; then export TERM=xterm-256color 
fi

It happens to me on all installed archlabs distro, I have 5 now this thing, don’t you?

#9

ok sorry yeah you must have “sudo top” screen shot which shows kworker processes.

maybe systemd journalctl can help here?

journalctl -fp err

#10

now it works completely normal, it happens only if I leave the session that the bash are started.

[don@don-pc ~]$ journalctl -fp err
-- Logs begin at Sat 2018-08-04 17:42:41 CEST. --
ago 05 15:58:09 don-pc kernel: ACPI Error: Method execution failed \_SB.ACCL._STA, AE_NOT_EXIST (20180313/uteval-69)
ago 05 15:58:09 don-pc kernel: kvm: disabled by bios
ago 05 15:58:09 don-pc kernel: kvm: disabled by bios
ago 05 16:18:24 don-pc sudo[18933]:      don : a password is required ; TTY=pts/3 ; PWD=/home/don ; USER=root ; COMMAND=list /usr/bin/pacman --color auto -S extra/xf86-input-synaptics
-- Reboot --
mag 07 17:35:06 don-pc kernel: ACPI Error: No handler for Region [RAM_] (00000000dc585333) [EmbeddedControl] (20181213/evregion-132)
mag 07 17:35:06 don-pc kernel: ACPI Error: Region EmbeddedControl (ID=3) has no handler (20181213/exfldio-265)
mag 07 17:35:06 don-pc kernel: ACPI Error: Method parse/execution failed \_SB.ACCL._STA, AE_NOT_EXIST (20181213/psparse-531)
mag 07 17:35:06 don-pc kernel: ACPI Error: Method execution failed \_SB.ACCL._STA, AE_NOT_EXIST (20181213/uteval-69)
mag 07 17:35:07 don-pc kernel: kvm: disabled by bios
mag 07 17:35:24 don-pc lightdm[1107]: gkr-pam: unable to locate daemon control file

sudo top

#11

Are you using any custom bash scripts in your polybar?

And what method are you using to log in?

#12

I think it is lightdm as shown on the journactl error log. Try using xorg-xinit to startx.

1 Like
#13

anwer 1 yes
script bash on polybar

;; Music         ;;
;;;;;;;;;;;;;;;;;;;
[module/youtube-dl]
type = custom/script
interval = 5
label = "%{A1:$HOME/.config/polybar/scripts/youtube-dl.sh:} %{A3:$HOME/.config/polybar/scripts/youtube-dl.sh:} %output% %{A} %{A}"
exec = echo ""
format = <label>
format-background = #0d000000

;;;;;;;;;;;;;;;;;;;;;;;;
;; GTK-YOUTUBE-VIEWER ;;
;;;;;;;;;;;;;;;;;;;;;;;;
[module/gtk-youtube-viewer]
type = custom/script
interval = 5
label = "%{A1:$HOME/.config/polybar/scripts/gtk-youtube-viewer:} %{A3:$HOME/.config/polybar/scripts/gtk-youtube-viewer:} %output% %{A} %{A}"
exec = echo ""
format = <label>
format-background = #0d000000

[module/radio]
type = custom/script
interval = 5
label = "%{A1:$HOME/.config/polybar/scripts/pmrp2:} %{A3:$HOME/.config/polybar/scripts/pmrp2:} %output% %{A} %{A}"
exec = echo ""
format = <label>
format-background = #0d000000
;Nobel's Radio Player

;[module/autohide]
;type = custom/script
;exec = /home/don/.config/polybar/scripts/autohie.py
;tail = true
;interval = 3600
;format-underline =#F881CE


[module/localip]
type = custom/script
; this line needs to be full path
exec = /home/don/.config/polybar/scripts/getip.sh
; add an icon

format-prefix = “”
label-padding = 2
interval = 600
format-prefix-foreground = ${colors.foreground}
format-prefix-background = ${colors.background}
label-background = ${colors.background}

[module/openweathermap-fullfeatured]
type = custom/script
exec = ~/.config/polybar/openweathermap-fullfeatured.sh 
interval = 600
label-font = 3
format = <label>
label-separator = |

the second question I didn’t understand what I mean but from openbox I click on:
Exit Openbox

I want to reiterate that it happens to me even in archlabs where I installed by default the minimum necessary so no bash script.
Thank

1 Like
#14

I meant how do you log in; do you use a display manager like lightdm, or do you use startx?

Does top have a tree view like htop? If so, can you post a screenshot of that after you replicate your issue.

#15

lightdm

1 Like
#16

Thanks; try what @s7l recommended.

#17

I think I found the problem is hideIt.sh, at least looking. htop to you that looks like?

#18

https://bugs.archlinux.org/task/62140

1 Like
#19

glad you got it fix ector.

#20

Use the F5 key in htop and that list will switch to tree mode; look like output from pstree command.

I want to reiterate that it happens to me even in archlabs where I installed by default the minimum necessary so no bash script.

But hideIt.sh isn’t installed by default is it? Is hideIt.sh the script that adds autohide to polybar?

Great if you’ve fixed your issue.