Trying to upgrade fron v5.0.0 and

I cant get past all the dependencies

sudo pacman -Syyu
[sudo] password for user:
:: Synchronizing package databases…
core 130.9 KiB 1769K/s 00:00 [----------------------------] 100%
extra 1663.7 KiB 2.84M/s 00:01 [----------------------------] 100%
community 4.5 MiB 2.97M/s 00:02 [----------------------------] 100%
multilib 170.2 KiB 1280K/s 00:00 [----------------------------] 100%
:: Starting full system upgrade…
:: Replace compositeproto with extra/xorgproto? [Y/n]
:: Replace damageproto with extra/xorgproto? [Y/n]
:: Replace dmxproto with extra/xorgproto? [Y/n]
:: Replace fixesproto with extra/xorgproto? [Y/n]
:: Replace fontsproto with extra/xorgproto? [Y/n]
:: Replace gnome-themes-standard with extra/gnome-themes-extra? [Y/n]
:: Replace inputproto with extra/xorgproto? [Y/n]
:: Replace kbproto with extra/xorgproto? [Y/n]
:: Replace mime-types with extra/mailcap? [Y/n]
:: Replace pkg-config with core/pkgconf? [Y/n]
:: Replace randrproto with extra/xorgproto? [Y/n]
:: Replace recordproto with extra/xorgproto? [Y/n]
:: Replace renderproto with extra/xorgproto? [Y/n]
:: Replace rfkill with core/util-linux? [Y/n]
:: Replace scrnsaverproto with extra/xorgproto? [Y/n]
:: Replace videoproto with extra/xorgproto? [Y/n]
:: Replace xextproto with extra/xorgproto? [Y/n]
:: Replace xf86dgaproto with extra/xorgproto? [Y/n]
:: Replace xf86vidmodeproto with extra/xorgproto? [Y/n]
:: Replace xineramaproto with extra/xorgproto? [Y/n]
:: Replace xproto with extra/xorgproto? [Y/n]
resolving dependencies…

looking for conflicting packages…
error: failed to prepare transaction (could not satisfy dependencies)
:: ffmpeg2.8: installing libvpx (1.7.0-1) breaks dependency ‘libvpx.so=4-64’
:: ffmpeg2.8: installing libx264 (2:152.20171224-2) breaks dependency ‘libx264.so=148-64’
:: ffmpeg2.8: installing x265 (2.8-1) breaks dependency ‘libx265.so=116-64’
:: libxfont: removing fontsproto breaks dependency ‘fontsproto>=2.1.3’

Remove ffmpeg2.8 and libxfont packages.

If the VLC application complains remove it as well.

Then reattempt upgrade.

1 Like

xorg-bdftopcf: removing libxfont breaks dependency ‘libxfont’

Try this:

sudo pacman -S libxfont2
sudo pacman -Rs libxfont
sudo pacman -Syu

sudo pacman -Rs libxfont
checking dependencies…
error: failed to prepare transaction (could not satisfy dependencies)
:: xorg-bdftopcf: removing libxfont breaks dependency ‘libxfont’

sudo pacman -Rs libxfont xorg-bdftopcf
checking dependencies…
error: failed to prepare transaction (could not satisfy dependencies)
:: xorg-font-utils: removing xorg-bdftopcf breaks dependency ‘xorg-bdftopcf’

sudo pacman -Rs libxfont xorg-bdftopcf xorg-font-utils
checking dependencies…
error: failed to prepare transaction (could not satisfy dependencies)
:: gsfonts: removing xorg-font-utils breaks dependency ‘xorg-font-utils’
:: terminus-font: removing xorg-font-utils breaks dependency ‘xorg-font-utils’
:: ttf-droid-font: removing xorg-font-utils breaks dependency ‘xorg-font-utils’
:: xorg-fonts-misc: removing xorg-font-utils breaks dependency ‘xorg-font-utils’

rebooted and tried again, no dice

xorg-bdftopcf should not depend on libxfont.
That package is no longer in Arch repos.

What is the output of:
sudo pacman -Syu xorg-bdftopcf

@LizziAS We all have our own reasons for doing things but have you considered installing a more recent release of ArchLabs? I ask because several of the dependency issues being barked by pacman, are several months old and I’m concerned the system has not been updated regularly enough. 5.0 is now fairly old and enormous improvements have been made to both the system in general and it’s installer.

1 Like

Wow! 5.0, that’s well over 12 months old that release. I’d highly recommend you install 2017.07 and avoid any of the above :). I know fresh installs are a pain but it is probably the easiest way to avoid any cock-ups at this point.

1 Like

OK that works, sorta. The WiFi is very sketchy compared to v5 and even to the install USB of 2018.07. After install the WiFi connection is slow and barely works and where the WiFi icon should be in get a constant switching between forward slash and back slash

Well I updated the new install and rebooted an my WiFi is actually worse than before the update and far worse than the live USB WiFi connection as one of my networks (5ghtz whatever it is) is no longer visible

Even so, it’s still better than the WiFi connection I got from another arch based open box distro.

Say what you want about me using version 5, it worked great for my wifi

Please post from terminal results from inxi -N , lets see what could be done about the network issue.

Edit: your AL version 5 installed already! Wonder if one can hold these dependencies unless these have security issues.

Edit2: Reread the thread & corrected accordingly.

I installed your version only presently 2018.07

Ok , thx for the comeback in there.

Inxi didn’t run then I realized I’m not fully updated. Once these updates finish I’ll try installing inxi. Could be awhile. 80k a sec is my top do speed presently with typical between 30 and 60

Aria2 gave me many errors but wget seems more friendly

Thx for the comeback , hope issues can be fixed !

Wget failed

Inxi is not in the repo, so I should build from aur?

Well, that’s odd. It should be @LizziAS.

Did you install the official stable release from SourceForge or the ‘testing’ release from google drive?

from sourceforge

im installing base-devel now just to be sure i have it all when i go to build inxi

sudo pacman -Syyu

followed by

sudo pacman -S inxi

Should be all that’s required.

as soon as base-devel is done ill try it again

so far 8 packages of 28 have donloaded its gonna be a while

1 Like