Trouble with Arch Linux on MSI Alpha 15

Please share same log with uninstalled amdgpu

This time when system hangs, log file is either corrupted or empty. When it works, logs look like this:

I also tried installing adm-pro-libgl. I’m only getting black screen with the mouse pointer in sddm.

There are some errors which can be related:

[     3.850] (EE) Failed to load module "ati" (module does not exist, 0)
[     3.851] (WW) Warning, couldn't open module fbdev
[     3.851] (EE) Failed to load module "fbdev" (module does not exist, 0)
[     3.851] (II) LoadModule: "vesa"
[     3.851] (WW) Warning, couldn't open module vesa
[     3.851] (EE) Failed to load module "vesa" (module does not exist, 0)
...
[     3.853] (II) LoadModule: "glamoregl"
[     3.853] (II) Loading /usr/lib/xorg/modules/libglamoregl.so
[     3.856] (II) Module glamoregl: vendor="X.Org Foundation"
[     3.856] 	compiled for 1.20.8, module version = 1.0.1
[     3.857] 	ABI class: X.Org ANSI C Emulation, version 0.4
[     3.861] couldn't get display device
[     3.861] (EE) modeset(0): glamor initialization failed
...
[     5.177] (EE) Failed to open authorization file "/var/run/sddm/{e88e77b2-82da-445c-b5a4-06dc8f1fce0f}": No such file or directory

Not sure what exactly causing your errors, but i’d start from checking each of them, one by one. Hope will have some time later tonight to check. And you can start to look into it already.

Well, I’m about to give up. After 2 sleepless nights I only managed to install vanilla Arch, which hangs randomly, and Ubuntu. The latter seems to work well, but the secondary display does not work. And even if it worked, I’m not going to get back to Ubu.

Have a nice sleep, might get better afterward !

Do you have these packages installed?

sudo pacman -S mesa xf86-video-vesa xf86-video-ati xf86-video-amdgpu xf86-video-fbdev

I don’t think you actually need the ati driver but perhaps I’m wrong, just going off the errors in one of your logs.

After latest messing with drivers I was unsure. Installed all you named, and now the machine doesn’t start at all. Hangs after “Started version 245.5-1-arch”.

Try dropping just the ati driver and see if anything changes.

I’ll need chroot, as it doesn’t boot…

Again you’re trying nomodeset?

Adding nomodeset results in some trash at the top of the screen, and it hangs.

Gotcha, my bad.

Removal of xf86-video-ati didn’t help. Still doesn’t start.

Just scouring around for similar issues elsewhere, check dmesg once you get it to boot again.

I uninstalled all one by one. The last was xf86-video-amdgpu, and after its removal the machine started. Probably because I have MODULES=(amdgpu) in /etc/mkinitcpio.conf.

This would be why nomodeset is not working, you’re using early kms.

I would try removing it from the modules, rebuild initramfs, and see what happens then.

Done, but it doesn’t start.

Ok, damn man can’t get a break lol, you’ve got no early kms and amdgpu installed?

Anything of interest in dmesg?

dmesg | grep -i 'warn\|error'

Early kms disabled, installed all the stuff you mentioned: it hangs. As soon as I remove xf86-video-amdgpu, it starts.