Trouble with Arch Linux on MSI Alpha 15

Interesting, never done it myself.Lets hope it will be alright.

Hopefully someone will chim in & give adavices.

1 Like

Back up your data etc …

Good call @PackRat

Something that I should be doing but never do !

These kids right !

LOL, I’ll simply copy all the ~/ folder, as usually. :slight_smile:

Judging from what I’ve recently found on the web, it’ll make no sense to use the old install on SATA ssd. The new drive (M.2 PCIe) should be way faster.

Wonder how many uses M.2 PCIe on Linux installs, lol, Not much techy on my end.

Hell knows, but I hope it’ll work. Same applies to the 5500M graphics. There’s no proprietary Linux driver. Interesting how the opensource one works - if at all.

Well , we ll see !

I think you’ll have to regenerate the initramfs, the stock mkinitramfs.conf uses the autodetect hook and so won’t include the nvme modules for your new drive. You can add them manually in the MODULES section, that might work, but there may be other modules missing. Load up a live ISO image then arch-chroot in and rebuild it from there on the new hardware to catch everything.

Not sure how dracut works (I haven’t tried it in Arch) but I imagine it’s similar: https://wiki.archlinux.org/index.php/Dracut

I have an M.2 drive, it’s hellafast :grin:

The open source amdgpu driver out-performs the proprietary AMDGPU-PRO driver for almost all tasks, see Phoronix for more on this.

1 Like

Thx for the comeback @anon42040838 . Didn t know or remember you having an M.2

Many thanks for tips. I think I’ll finally give up on trying to use the old install, but good to know how to do it if necessary. It seems I’m going to have enough fun this weekend. May delivery be on time. Can’t wait. :slight_smile:

@anon42040838, could you tell me if xf86-video-amdgpu and xf86-video-ati are alternative drivers or should they be installed together? I’m feeling lost. BTW: nothing works well on the new machine so far. :frowning:

You need one of them, and I am using amdgpu myself with Vega64.
Please check https://wiki.archlinux.org/index.php/AMDGPU and https://wiki.archlinux.org/index.php/Xorg#AMD

I’ve been reading both since yesterday, but still no major progress: connecting the secondary hdmi display crashes X.

Your hardware won’t use xf86-video-ati but you don’t actually need either, X.Org’s builtin modesetting driver should work.

If you posted the log and your full configuration then we might be able to help.

I’ll do it ASAP. We’re having some internet failure, and I can only connect by my mobile. Unfortunately I didn’t configure wi-fi on the laptop.

@anon42040838 alright, I used my Chromebook. Wish I understood this:

One more thing: if I set legacy boot in BIOS, I see installer messages on the secondary screen for a while, before they freeze. While booting EFI the hdmi screen just turns on (still black) and goes off after several seconds.

Laptop specs:

  • AMD Ryzen 7 3750H
  • AMD Radeon Vega 10
  • AMD Radeon Pro 5500M

Can you uninstall all the drivers but mesa? From the logs it seems it uses amdgpu. Maybe let’s start with simplest drivers set.

You can try to connect your phone with cable as modem to your laptop.

I did so, no change.

I was looking for the firmware update, but it can only be done on Windows 10. Fuck.