Trouble resolving installation issues with Openbox and lightdm

I’ve spent more than 12 hours trying to install Archlabs Openbox with lightdm (no LUKS, LVM, or such), but I wasn’t able to succeed in spite of following some forum threads suggesting solutions for similar problems. archlabs_2020.05.04

Errors and warnings I can pick up on (by using Ctrl-Z and reading the output carefully):

  • Setting locale failed came up twice
  • iputils-20190709-3 is up to date --skipping
  • Failed to open file "/sys/devices/system/cpu/microcode/reload": Read-only file system error: command failed to execute correctly came up twice
  • sed: can't read /mnt/sudoers: No such file or directory
  • iputils-20190709-3 is up to date --reinstalling
  • WARNING: Possibly missing firmware for module: wd719x
  • WARNING: Possibly missing firmware for module: aic94xx
  • There might be another warning or error which get overwritten by the installer’s first error warning prompt

After attempting to handle first error prompt

  • complained that lightdm is missing, but I found a spelling mistake in the previous pacstrap command which I believe is the source of this particular bug: bash-completionlightdm instead of bash-completion and lightdm

In the resulting installation only the root user is accessible with the root password (when auto-login was not selected) and the WM cannot lauch since startx is missing (packages did not install?)

I also did an install without selecting a WM and login manager planning to do this after I get it running successfully. In this case the installer does not halt, but I can see similar warning and errors in the output as it scroll off screen. The users seem to be set up correctly this time, however, when I tried to install neovim the installation was refused due to corrupted package msgpack-c-3.3.0-1

Finally successfully installed Archlabs using this beta iso:

Some of the same error messages were still in the output, but the installer didn’t seem to mind them this time.

Glad that you installed it yourself @bedtimeparadox