Tried to reinstall AL, but

I’m going to try today sometime, when I have the time to do so. I am hoping that it’s just a fluke. I will post the results asap.

@nate and @Dobbie03, it was a failure. I’m still getting the same errors. I can’t install because it doesn’t detect my internet. But when I did a system update while on live and it’s updating. So, connecting to my internet. I’m wondering if something in systemctl or one of the config files has a bug. After the update, I tried again to install, but get No network connection detected! Open Connection Dialogue? box. So I tried connecting to my wifi. Clicked on the pull down menu, it says it’s connected. Clicked installer again, same box comes up even though it says in the pull down I’m connected. Can’t get past Network Check to continue to install. I did

ping -c 3 www.google.com
www.google.com ping statistics
3 packets transmitted, 0 received, 100% packet loss, time 2035ms

Yet, I get update info streaming in with no issue. The mirrorlists were able to connect. Could there be an issue with NetworkManager?

Well it shouldn’t be very hard of a fix either way, here’s what the ‘installer’ really is doing,
mainly just look for the last ~10 lines.

If you have network connection all you need to do is install the installer package with pacman, then run it as root, could debug it to see where its failing but no need.

I imagine it’s due to using google’s dns server address rather than web address :man_shrugging:

[[ -e /run/archiso/bootmnt && $TERM == "linux" ]] && setfont ter-116n

while ! ping -c 1 8.8.8.8 &>/dev/null; do
    bt=" Archlabs Installer "
    ttl=" Network Check "
    msg="\nNo network connection detected!"
    if [[ $(systemctl is-active NetworkManager) == "active" ]]; then
        msg="$msg\n\nOpen Connection Dialog?"
        if dialog --backtitle "$bt" --title "$ttl" --yesno "$msg" 0 0; then
            nmtui
        else
            exit 0
        fi
    else
        dialog --backtitle "$bt" --title "$ttl" --msgbox "$msg\n\nExiting..." 0 0
        exit 0
    fi
done

if ! pacman -Qq "archlabs-installer" &>/dev/null; then
    clear
    echo -e "\nUpdating the installer... Please Wait\n"
    sudo pacman -Sy archlabs-installer --noconfirm
fi

clear
echo -e "\nLaunching the installer...\n"
sleep 1
sudo /installer/installer

Run this line if you want to debug and see if my assumption was correct, after, run the same but use google.com instead of 8.8.8.8

! ping -c 1 8.8.8.8 &>/dev/null && echo "Not Connected" || echo "Connected"

You can also just edit this script which is what I pasted above in /usr/bin/al-installer and just edit it to whatever ping worked for you, there is also one other script which simply sets termite’s font bigger and makes the background opaque, then launches the script above, but it’s purely aesthetic

Very possibly, as you can see in the script above, $(systemctl is-active NetworkManager) is used to check if we can just open nmtui (cli based network connection editor), after failing the ping check. Do you get the option to open a connection dialog??

Do you get the option to open a connection dialog?

Yes, I do get an option to open a connection dialogue, this was how I was able to connect with wifi. Also, while in the dialogue I found that my ethernet connection was also active. This why I was questioning there was an issue with systemctl dealing with NetworkManager. I will try your script tomorrow evening to see if works. This is an odd quirk, but I am sure we’ll figure it out soon.

That is what’s running everytime you click the install option in the openbox menu :slight_smile:

Got it. Just figured something small was out of the ordinary.

Just never know man, always seems to be something XD

I joked one time that at this rate of solving all the issues, we may someday solve all the ancient mysteries of this world. :grin:

2 Likes

We can only hope XD

1 Like

When I do sudo pacman -Syu:
> liveuser@archlabs ~ % sudo pacman -Syu
> :: Synchronizing package databases…
> core is up to date
> extra 1608.3 KiB 282K/s 00:06 [----------------------] 100%
> community 4.4 MiB 204K/s 00:22 [----------------------] 100%
> multilib is up to date
> archlabs_repo is up to date
> :: Starting full system upgrade…
> resolving dependencies…
> looking for conflicting packages…
>
> Packages (20) alsa-firmware-1.0.29-2 boost-libs-1.66.0-3
> broadcom-wl-6.30.223.271-19 ffmpeg-1:4.0-3 fftw-3.3.8-1
> idnkit-1.0-4 imagemagick-7.0.7.37-1 kmod-25-1 liblqr-0.4.2-2
> libmagick-7.0.7.37-1 linux-4.16.12-1 pacman-5.1.0-1
> virtualbox-guest-modules-arch-5.2.12-5 volume_key-0.3.10-1
> wipe-2.3.1-4 x265-2.8-1 xorg-font-util-1.3.1-2
> xorg-setxkbmap-1.3.1-2 xorg-xev-1.2.2-2 zip-3.0-8

But, going back to installer it shows that dialogue box. I did change to google.com, but that didn’t work. I installed the echo line for diagnostic testing and even that wouldn’t work. So, I thought let’s go back one version, which is 2018.3. That version has no issues, it went directly to install AL.

Version 2018.6 seemed to have fixed this issue. If anyone else runs into this issue running 2018.5, I recommend using 2018.6.

Okay, it’s been about 2 weeks and I can’t get Archlabs of any version to reboot correctly after installing. It keeps hanging after choosing Archlabs from grub. I can get to tty2.

starting version 238
/dev/sda4: clean, 425159/29958144 files, 4773224/119805440 blocks
Then get Failed to get diagnostic page 0x1
Failed to bind enclosure -19

[sdc] Assuming drive cache: write through
Then I get a blinking cursor. Every thing that I have tried failed to pass this point.

Hi guys!

Just installed 2018.06 successfully yesterday. Reboot is working well and generall internet connection is no problem.

BUT, when I try to connect my IMAP account in thunderbird or evolution I get connection refused. nslookup to my mailserver works fine. I thought it was a mailserver issue but mailserver could be reached from iphone in same wlan without any issue.

I also can not connect to the internet with teamviewer 13. I get no teamviewer id and can not login with my teamviewer account. also minecraft is not connecting but this is not the hardest problem at this moment :smiley:

EDIT: geary was able to make a connection :smiley:

EDIT2: TeamViewer 12 is able to connect to the internet

maybe we can find a solution together :wink:

Hi everyone,

I know this is an old post but this is the exact issue I am having right now. I am trying to install AL 2018.05 and I am having the same issue as @sevenday4 I am getting the network connection issue.

I did try to run

! ping -c 1 8.8.8.8 &>/dev/null && echo “Not Connected” || echo “Connected”

And it did say “Connected”

I ran system update inside the live usb and was able to update all 240+ updates

@Dobbie03 @natemaia @sevenday4

Finally I was able to install using 2018.05 I changed github.com to google.com on this par of the installer

    req_chk() {
    if [[ $(whoami) != "root" ]] || ! ping -c 1 www.google.com &>/dev/null; then
        [[ $(whoami) != "root" ]] && msg="${_NotRoot}$_Exit" || msg="$_NoNetwork"
        dialog --backtitle "$BT" --title " $_ErrTitle " --infobox "$msg" 0 0
        sleep 3
        [[ $(whoami) != "root" ]] && exit 1
        fi
        echo "" > $ERR

Since it was something about connections I checked the installer script on which part it tries to check if I am connected to the internet… I found out (not sure if it just me or my connection) that I cannot ping github.com from where I am at and that is the reason why the installer kept telling me that I do not have an internet connection

1 Like

+1 for figuring it out on your own, this issue has been solved with more current releases.

Originally we were pinging google, but many users were having issues with that for the same reason, so now we just use many sites :smiley:

(ping -c 1 archlabslinux.com || ping -c 1 bitbucket.org || ping -c 1 github.com || ping -c 1 sourceforge.net)

Wonder if that would be of any help here before upgrading on fresh installs to the ones installing AL;

@punksinatra , top job in there mate.

EDIT: I think I found it here https://sourceforge.net/projects/archlabs-linux-minimo/files/ArchLabsMinimo/. The description to the link got me fooled because it says “Previous Releases”

Yeah I read from previous posts here there is a 2018.06 installer but when I go to the download “get” page I only get offered 2018.05

Can I ask for the link to the updated versions please. Thanks

This one ! But it s a testing iso if you don t mind, @natemaia worked much to update it lately;