ArchLabs Linux

Tray icon solution & notifications

I have to say, I LOVE THE ArchLabs polybar SETUP, I MEAN I LOVE IT, but 1 problem with it, no tray
Any tips on what i should use for I3 or BSPWM, and even Openbox as a tray solution? I use Skype, Discord, Variety, Dropbox, and a few more apps that require a tray

second tip i need is, more of a question, from Skype Discord etc etc, I’m getting notifications from the workspace, can i move the possition of the notifications to the right side of my screen? and how?

Did you try to enable the polybar system tray? -

polybar configuration

1 Like

What @PackRat said. I have this in my config:

tray-position = left
tray-padding = 5
tray-background = ${colors.alt.background}

Edit it to suit your setup.

Yeah, as above. Mine is on the right most times…

tray-position = right
tray-padding = 10
tray-background = ${colors.background}
tray-offset-x =
1 Like

I googled about it and found that Polybar doesnt have a tray module :smiley: hm… i have tried both of your suggestions, and i get an error in my i3 config

Enable the tray in your polybar config file, not the i3 config file.

1 Like

Yeah it just accured to me mate HAHAHah WHAT A FAIL :smiley: I did it when i woke up :smiley: hahah

anyways, this is what i added to my polybar config

tray-position = right
tray-padding = 5
tray-background = ${colors.alt.background}

when i save the file, on the top right side of polybar something shows up and dissapears right away … :-/

Is

A valid colour option in your polybar config?

i tried

tray-position = right
tray-padding = 5
tray-background = ${colors.background}

as well … it keeps dissapearing … do i need to install anything to make it work or?

Can you please share your config. I’ll take a look.

But before you do that, run in the terminal polybar -r POLYBAR NAME" and see if it outputs any error regarding the tray.

try like this
wm-restack = i3 or yours wm
edit

; Currently supported WM's:
;   bspwm
;   i3 (requires: `override-redirect = true`)
; wm-restack =

my polybar config is the default one that gets provided with the i3 install of ArchLabs, didn’t change a single thing except that i added the recommended lines at the bottom of it … will share it in a few hours, busy these days

@Dobbie03

└> $ polybar -r "i3-bar"
warn: No monitor specified, using "DVI-I-1"
error: tray: Failed to put tray above 0x2200002 in the stack (XCB_MATCH (8))
warn: Systray selection already managed (window=0x1400008)

config file: https://pastebin.com/QAZcvVAs

This tells me you already have a systray running. Are you running another bar like tint2 or something similar that is using systray as well?

Check in arandr if this is the actual name of your monitor as polybar doesn’t recognise it.

Also, what’s up with this in your config?

modules-right  = ${env:POLYBAR_MODULES:coreuse temperature memory pkg network volume}

I’d change it to this:

modules-right  = coreuse temperature memory pkg network volume

@Dobbie03
No i do not have any sys tray running at all (or at least i think so), I have used archlabs-installer, setup my partition, setup my username and password, picked a WM (i3-gaps from the installer) picked a few additional software (browser, terminals, and similar stuff) and installed the system, and even the config file I got for polybar is the default polybar config file supplied from ArchLabs-Installer so I have no clue what do you mean whats up with that, as that’s what is supplied by your distribution as a default config file

Interesting, I hadn’t realised that the configs had been changed.

warn: Systray selection already managed (window=0x1400008)

Means that the system tray is already being managed elsewhere.

Have you tried deleting your polybar folder and cloning from BitBucket and starting again.

https://bitbucket.org/archlabslinux/pkgbuilds/src/master/archlabs-polybar/

@kronikpillow - I haven’t been following this thread closely, but are you running polybar as well as the native i3 (i3-gaps) bar? The system tray for the i3bar is on by default, you can disable it (see the user guide in the docs section of i3 home page). Or remove the bar stanza from the i3 config to disable the i3bar completely.

see

@PackRat no I’m not using the i3 bar, I have no tray at all, and i checked the i3 config there is no tray in the config, I’m using a clean blank install of ArchLabs I3, with it’s default configs and setup for, I have tried placing the i3 blocks bar and tray and disabled the polybar, and even the i3 bar doesn’t have a tray … So i really don’t know whats up with this …

@Dobbie03 I dunno if things have changed from before or not, it’s just a tought, and No i have not tried deleting my polybar config and installing the one from https://bitbucket.org/archlabslinux/pkgbuilds/src/master/archlabs-polybar/ because it’s identical to the one I have on my system, I have checked on bitbucket, It’s basically the same thing I have installed