Timeshift problem

Before I dig myself into a bigger hole, does anyone have an idea what should I do first?
Wanted to do a backup today but it looks like Timeshift doesn’t see my backup partition anymore, the partition is there and I’ve used it many times before and I have a few snaps stored on it, check the screenshot:

Has your fstab file changed?
Check the UUID=

1 Like

same uuid

1 Like

post,

$df -h

$sudo blkid

May help if you run

$sudo mount -a

Filesystem Size Used Avail Use% Mounted on
dev 7.8G 0 7.8G 0% /dev
run 7.8G 18M 7.8G 1% /run
/dev/sda2 293G 249G 44G 86% /
tmpfs 7.8G 124M 7.7G 2% /dev/shm
tmpfs 7.8G 83M 7.7G 2% /tmp
/dev/sda1 999M 2.2M 996M 1% /boot/efi
> /dev/sda6 80G 68G 7.9G 90% /home/x/backup
tmpfs 1.6G 64K 1.6G 1% /run/user/1000

/dev/sda2: LABEL=“Arch” UUID=“dc03ba38-49bf-4972-85c1-b5bd52da945e” UUID_SUB=“ac169371-ed64-46b7-893d-523388ec2d49” BLOCK_SIZE=“4096” TYPE=“btrfs” PARTUUID=“20bd8ec8-02”
/dev/sda5: LABEL=“archcraft_sda6” UUID=“5d1d0c12-a7e7-405c-b0cb-16ce285b5c13” BLOCK_SIZE=“4096” TYPE=“ext4” PARTUUID=“20bd8ec8-05”
/dev/sda3: UUID=“3bb39cc8-e5bb-4479-98e6-4e4f091eedc7” TYPE=“swap” PARTUUID=“20bd8ec8-03”
/dev/sda1: UUID=“F261-DF7B” BLOCK_SIZE=“512” TYPE=“vfat” PARTUUID=“20bd8ec8-01”
/dev/sda6: LABEL=“backup” UUID=“23077958-7a18-47d3-87c1-634d942ce10f” BLOCK_SIZE=“4096” TYPE=“ext4” PARTUUID="20bd8ec8-06"

ooo

cat /etc/timeshift/timeshift.json
“backup_device_uuid” : “23077958-7a18-47d3-87c1-634d942ce10f”,
“parent_device_uuid” : “”,

Did the same setup ever work before? What’s your running kernel?

It appears to be a timeshift issue. However, if it worked before and you have 5.12.x kernel, you may try the LTS version. 5.12.x has caused countless problems so far.

Some other users have similar problem. Post your problem here.. The owner of timeshift may have the answer.

PS: It’s recommended to use a BTRFS snapshot on a system installed on BTRFS file systems.

“It is strongly recommended to use BTRFS snapshots on systems that are installed on BTRFS partition. BTRFS snapshots are perfect byte-for-byte copies of the system. Nothing is excluded. BTRFS snapshots can be created and restored in seconds, and have very low overhead in terms of disk space.” –TeeJeeTech

My last backups were done on 5.12.3 and 5.12.4 and it worked, had no problems with this kernel so far.
I’m running 5.12.6

I downgraded to 5.12.4, then to 5.12.3 with system restarts, nothing changed, I’m 100% sure I did backups at least once with 5.12.3 and/or 5.12.4, this might not be a problem caused by the kernel.

I posted a comment there but it seems the other guys had no luck either, no answer to the same problem.

(Yes I wanted to do snapshots at first with btrfs but things looked too complicated compared to how easy it was with timeshift)

Give LTS a shot. If it doesn’t work either, we have to wait for TeeJee.

New patch available, timeshift problem solved, too bad that I stopped using it :smiley: I’ll just use rsync and do manual backups.

https://github.com/teejee2008/timeshift/issues/753

1 Like

So are they going to push the patch out? I ask cause I have no idea about editing the files. Only getting USB rescue mode.

1 Like

If updating doesn’t work, try removing Timeshift and install again from AUR, the patch is included in the aur package.

1 Like