Time Sync

A fellow was in IRC earlier… I guess time sync isn’t turned on by default… thought I would bring it up here in case it is missed…

Shesas> p5B0A382B.dip0.t-ipconnect.de/91.10.56.43 Hi there, are there any issues with ntp on ArchLabs? Sometimes my clock gets out of sync and even with “sudo systemctl stop ntpd; sudo ntpd -q -g -x -n; sudo systemctl start ntpd” it doesn’t change the clock correctly…
12:48:58 PM
7im4pple Not that I am aware of Shesas , how often is sometimes?
12:50:20 PM
p5B0A382B.dip0.t-ipconnect.de/91.10.56.43 Hm… nearly everytime I start ArchLabs (I run it in a VirtualBox VM). (If I stop ntpd, run sudo ntpdate 0.arch.pool.ntp.org and start ntpd again it does synchronize it manualy)
12:50:54 PM For example: I stop ArchLabs, save the current state and start it after five minutes… the clock does not get synchronized and is 5 minutes “behind” my local time
12:52:47 PM By the way: There are no unusual entrys ins syslog about ntpd
1:00:42 PM
7im4pple Maybe an issue communicating within the VM?
1:01:09 PM I have no issues on bare metal
1:01:27 PM I’ll try it out later…maybe throw it on a VM here at work.
1:01:53 PM You may want to ask on the Forums also… https://forum.archlabslinux.com/
1:03:13 PM
p5B0A382B.dip0.t-ipconnect.de/91.10.56.43 Could be, but even it it has problems, shouldn’t it update it via ntpd when it differs from the servers? Is there any way to see how often they are queried?
1:03:25 PM Thanks for the link, but it isn’t a large problem for me :smiley:
1:10:21 PM There is something really wrong with the clock… it seems to run faster than my host… I don’t have any issues with “pure” arch or any other linux distro in VirtualBox… hm…
1:31:48 PM Oh, I found the issue: After I added “iburst” behind every ntp server in the default /etc/ntp.conf it works fine. This should be fixed… hmm
1:51:24 PM And another thing: I had to use “timedatectl set-ntp true” to enable ntp sync automatically… something that should be enabled by default on a desktop distro :slight_smile:
1:53:57 PM
7im4pple Happy you got it figured out.
2:03:16 PM
p5B0A382B.dip0.t-ipconnect.de/91.10.56.43 Thanks, but anywhay… ArchLabs should consider it to be enable timesync by default :slight_smile: Bye :slight_smile:

1 Like

this is the best guide:
https://wiki.archlinux.org/index.php/Time