Thunar 4.17

Hi
I have the following version of Thunar installed:

1 extra/thunar 4.16.11-2 (1.2 MiB 6.3 MiB) [xfce4] (Installed)

I’d like to try out the 4.17 with split view

Does anyone use this &/or have any recommendations of which way to do this?
And how this would sit alongside my existing version?

1 Like

Oh, I was t aware of that version, I only have Thunar 4.16.10 installed.

Here s some info of 4.17;

https://9to5linux.com/xfces-thunar-file-manager-gets-split-view-file-creation-times-and-more

Edit; Not available on Debian s repo as of yet but only on Experimental Repo only.

3 Likes

Try this one,

aur/thunar-git 4.17.7+66+gc710d268-1 (+13 0.00)

It probably will overwrite your installed one.

4 Likes

:+1:
gonna try it on my VB AL first

1 Like

Well, got it ! Noe I have to experiment with this version.

thunar -V
thunar 4.17.11 (Xfce 4.16)

Copyright (c) 2004-2020
	The Thunar development team. All rights reserved.

Written by Benedikt Meurer <benny@xfce.org>.

Please report bugs to <https://gitlab.xfce.org/xfce/thunar>.
2 Likes

Cool!
Mr ‘guinea pig’ Altman to the rescue :smile:
Did it overwrite your existing Tunar then i guess?
Any explosions or blood? :rofl:

1 Like

Lol, it s rather unusual !

2 Likes

Did you have to install 3 missing dependencies?

1 Like

Shit, I haven t noticed, I rebooted so I can t see what was installed or upgraded.

Their was like 7-8 updates, but I don t remember if their was any new dependencies .

1 Like

Lol, now I need some big meds !

1 Like

I get the below on my lappy with :

leigh@archlabs ~ % thunar -V
thunar 4.16.11 (Xfce 4.16)

Copyright (c) 2004-2020
	The Thunar development team. All rights reserved.

Written by Benedikt Meurer <benny@xfce.org>.

Please report bugs to <https://gitlab.xfce.org/xfce/thunar>.
leigh@archlabs ~ % yay thunar-git
3 aur/rabbitvcs-thunar-git r1893.b88b384-1 (+0 0.00) 
    Thunar extension for RabbitVCS
2 aur/gtkhash-thunar-git v1.4.r64.g3afea16-1 (+1 0.00) 
    A Thunar filemanager plugin for computing message digests or checksums (development version).
1 aur/thunar-git 4.17.7+66+gc710d268-1 (+13 0.00) 
    file manager for xfce
==> Packages to install (eg: 1 2 3, 1-3 or ^4)
==> 1
 -> Could not find all required packages:
	exo>=4.17.0 (Wanted by: thunar-git)
	libxfce4ui>=4.17.2 (Wanted by: thunar-git)
	libxfce4util>=4.17.1 (Wanted by: thunar-git)
leigh@archlabs ~ % yay thunar-dev
1 aur/thunar-devel 4.17.11-1 (+13 0.11) 
    File manager for Xfce (development version)
==> Packages to install (eg: 1 2 3, 1-3 or ^4)
==> 1
 -> Could not find all required packages:
	exo>=4.17.0 (Wanted by: thunar-devel)
	libxfce4ui>=4.17.6 (Wanted by: thunar-devel)
	libxfce4util>=4.17.2 (Wanted by: thunar-devel)
leigh@archlabs ~ %
1 Like

Wonder if you have to reboot, it s what I had to do in order to see the newer Thunar version oddly enough ! On that command; thunar -V

Same as with my kernel versions, but one might only logout & relogin again, but it s the way I do things on my end ! lol .

2 Likes

I just presumed that I had to install those dependencies first

Ah:

8 aur/exo-devel 4.17.3-1 (+7 0.67) 
    Extensions to Xfce (Development version)
1 extra/exo 4.16.4-1 (315.0 KiB 2.2 MiB) [xfce4] (Installed)
    Application library for Xfce

2 aur/libxfce4ui-devel 4.17.8-1 (+15 0.11) 
    Commonly used Xfce widgets among Xfce applications (Development version)
1 extra/libxfce4ui 4.16.1-1 (347.0 KiB 1.9 MiB) (Installed)
    Commonly used Xfce widgets among Xfce applications

3 aur/libxfce4util-git 4.17.2.r22.ge2f2a6e-1 (+3 0.00) 
    Basic utility non-GUI functions for Xfce
2 aur/libxfce4util-devel 4.17.3-1 (+5 0.11) 
    Basic utility non-GUI functions for Xfce (development release)
1 extra/libxfce4util 4.16.0-1 (125.2 KiB 850.4 KiB) (Installed)
    Basic utility non-GUI functions for Xfce

@leigh , If you open Thunar & check for About Thunar, what it shows.

1 Like

4.16.11

like this as well:

leigh@archlabs ~ % thunar -V
thunar 4.16.11 (Xfce 4.16)

From here

https://archlinux.org/packages/?name=thunar

That s weird !

Anyways I can t take screenshots anymore ! Wonder if it has to do with the upgrade, which would not surprises me at all !

8 aur/exo-devel 4.17.3-1 (+7 0.67) 
    Extensions to Xfce (Development version)
7 aur/flexo-git 1.6.8.r0.g014ac76-1 (+7 0.00) 
    A central pacman cache
6 aur/exoscale-cli 1.59.0-1 (+7 0.01) 
    Command-line tool for everything at Exoscale: compute, storage, dns
5 aur/otf-exo 2.0-8 (+8 0.00) 
    A geometric sans serif font with a technological feel
4 aur/hexo-cli 4.3.0-6 (+11 0.00) 
    Command line interface for Hexo
3 aur/exo-git 1:0.12.11+68+ga978d108-1 (+26 0.00) (Out-of-date: 2022-10-15) 
    Extensions to Xfce originally developed by os-cillation.
2 aur/exodus 22.11.21-1 (+51 0.39) 
    Send, receive & exchange cryptocurrency with ease on the world's leading Desktop, Mobile and Hardware wallets. Bitcoin wallet
1 extra/exo 4.16.4-1 (315.0 KiB 2.2 MiB) [xfce4] (Installed)
    Application library for Xfce
==> Packages to install (eg: 1 2 3, 1-3 or ^4)
==> 8
 -> Could not find all required packages:
	libxfce4util>=4.17.2 (Wanted by: exo-devel)
leigh@archlabs ~ % yay libxfce4util
4 aur/libxfce4util-gtk2 4.14.0-1 (+1 0.00) 
    Basic utility non-GUI functions for Xfce (GTK2 version)
3 aur/libxfce4util-git 4.17.2.r22.ge2f2a6e-1 (+3 0.00) 
    Basic utility non-GUI functions for Xfce
2 aur/libxfce4util-devel 4.17.3-1 (+5 0.11) 
    Basic utility non-GUI functions for Xfce (development release)
1 extra/libxfce4util 4.16.0-1 (125.2 KiB 850.4 KiB) (Installed)
    Basic utility non-GUI functions for Xfce
==> Packages to install (eg: 1 2 3, 1-3 or ^4)
==> 2
:: Checking for conflicts...
:: Checking for inner conflicts...
 -> Package conflicts found:
 -> Installing libxfce4util-devel will remove: libxfce4util
 -> Conflicting packages will have to be confirmed manually
[Repo Make:11]  perl-xml-parser-2.46-4  intltool-0.51.0-6  docbook-xml-4.5-9  docbook-xsl-1.79.2-7  glib2-docs-2.74.2-1  python-anytree-2.8.0-5  gtk-doc-1.33.2-1  python-markupsafe-2.1.1-1  python-mako-1.2.4-1  gobject-introspection-1.74.0-1  vala-0.56.3-1
[Aur:1]  libxfce4util-devel-4.17.3-1

:: Remove make dependencies after install? [y/N]

Homer Simpson Backs Into Bushes | Know Your Meme

Guess that you can try later on, it might come to the repo !

1 Like

I eel bad about this :scream:

1 Like

Lol, part of updates right ! lol

1 Like