Thermal Problems, Kernel 5.10 - Latest, Intel Comet Lake - Latest

Hey guys,

I’ve got a wierd thing going on and don’t really know where to start troubleshooting it.

Basically I’m running Arch with 5.10 LTS on an Intel Comet Lake i5.

When leaving my ThinkPad docked to an external monitor/ keyboard the fan never really kicks on as long as I’m using it.

Now whenever I let it sit for a while and it screen blanks etc. The fan kicks on and it gets really hot after a while. Then whenver start using the periphials and unblank the screen it cools back down.

I just don’t get why it has to go into Turbo mode when I’m not using it then it throttles back down when I’m using it. Strange and don’t really know where to start trouble shooting this. Any ideas?

BTW this has happened on any distro I’ve tried with 5.10 or newer kernels.

Thanks,

Cog

This happens to my ASUS Ryzen 7 laptop also.
I never quite put my finger on it but I have resorted to putting a few xset option in my .xprofile.
For me this seems to work and I cant explain it.

xset dpms 0 0 0
xset -dpms

I know - it dont really make sense but perhaps it has something to do with hibernate etc.
I am curious what xset q shows on your system

Mine -
DPMS (Energy Star):
Standby: 0 Suspend: 0 Off: 0
DPMS is Disabled

1 Like

Thanks @Chris . I’ll try it out tomorrow. Will let you know my defaults and then what it does on this end.

@Chris so far so good. I’ll give you another update later after it “sits” for a little while. Also will give you some info from xset at that point. I think this is something everyone needs to know about with fairly new hardware.

1 Like

A wrinkle I found today too - I run Firefox and just like Chrome, it tries to run “accelerated”. With Firefox, it appears to be a number of threads to use. In my case, 8 - this also lead to overhearing and freeze-up.

Within FF, under Prefs and Performance, uncheck the box that says use recommended settings. Mine is defaulted at 8. I set it to either one or 2, and that helped out a good bit. Depending on how many tabs you run, you could easily see a huge amount of threads being used.

HTH

What type of video card/driver are you using in your system?

AMD ATI 03:00.0 Picasso (xf86-video-amdgpu)

@Chris thanks for the FF tip. All I use too.

So everything is still running “cool”. Gonna go ahead and mark this solved.

Here’s the info you were wanting:

BEFORE:

Keyboard Control:
auto repeat: on key click percent: 0 LED mask: 00000002
XKB indicators:
00: Caps Lock: off 01: Num Lock: on 02: Scroll Lock: off
03: Compose: off 04: Kana: off 05: Sleep: off
06: Suspend: off 07: Mute: off 08: Misc: off
09: Mail: off 10: Charging: off 11: Shift Lock: off
12: Group 2: off 13: Mouse Keys: off
auto repeat delay: 500 repeat rate: 20
auto repeating keys: 00ffffffdffffbbf
fadfffefffedffff
9fffffffffffffff
fff7ffffffffffff
bell percent: 50 bell pitch: 400 bell duration: 100
Pointer Control:
acceleration: 2/1 threshold: 4
Screen Saver:
prefer blanking: no allow exposures: no
timeout: 300 cycle: 300
Colors:
default colormap: 0x20 BlackPixel: 0x0 WhitePixel: 0xffffff
Font Path:
built-ins
DPMS (Energy Star):
Standby: 600 Suspend: 0 Off: 900
DPMS is Enabled
Monitor is On

AFTER:

Keyboard Control:
auto repeat: on key click percent: 0 LED mask: 00000002
XKB indicators:
00: Caps Lock: off 01: Num Lock: on 02: Scroll Lock: off
03: Compose: off 04: Kana: off 05: Sleep: off
06: Suspend: off 07: Mute: off 08: Misc: off
09: Mail: off 10: Charging: off 11: Shift Lock: off
12: Group 2: off 13: Mouse Keys: off
auto repeat delay: 500 repeat rate: 20
auto repeating keys: 00ffffffdffffbbf
fadfffefffedffff
9fffffffffffffff
fff7ffffffffffff
bell percent: 50 bell pitch: 400 bell duration: 100
Pointer Control:
acceleration: 2/1 threshold: 4
Screen Saver:
prefer blanking: no allow exposures: no
timeout: 300 cycle: 300
Colors:
default colormap: 0x20 BlackPixel: 0x0 WhitePixel: 0xffffff
Font Path:
built-ins
DPMS (Energy Star):
Standby: 0 Suspend: 0 Off: 0
DPMS is Disabled

1 Like

Hope it all works out - so far for me, it’s been a good thing.

Nice bud. The only change was that I’m doing it with .xinitrc instead of .xprofile since I don’t use a Display Manager. You gotta sleep it a tad to give Xorg a chance to start first.

my ~/.xinitrc in case anyone needs it:

(sleep 5s && xset dpms 0 0 0) &
(sleep 6s && xset -dpms) &
exec startxfce4

1 Like

@cog -
Have a look here also. Note the last messages. If you tend to have blanking screens, this will also help

https://bbs.archlinux.org/viewtopic.php?id=266386

1 Like

UPDATED and FINALIZED
So, as I worked through this I learned a thing or two (Farmers Insurance reference).

I started off by adding all my DPMS settings in .xprofile and for the most part, it all pretty much worked.
Further tweaking (and with the help of “The wiki”) I come up with what I feel, the perfect settings (for me at least)

In /etc/X11/xorg.conf.d I created a file called 10-monitor.conf that looks like this:
Section “ServerFlags”
Option “StandbyTime” “0”
Option “SuspendTime” “0”
Option “OffTime” “0”
Option “BlankTime” “0”
EndSection

All of my remaining DPMS lines from my .xprofile now reside in the file above.

I then installed xscreensaver and set it to no splash and created a user side systemd entry to auto start.
So far this works perfectly, no freeze ups, no screen silliness I had before, blanking is now consistent and the external monitor is playing very well. As an added feature, I also added the LTS kernel as a boot option should I ever need it. Thus far, the current kernel is fine with my settings.

The following links are provided for reference.
https://bbs.archlinux.org/viewtopic.php?id=266386
https://wiki.archlinux.org/title/Display_Power_Management_Signaling
https://wiki.archlinux.org/title/Xorg#Configuration
https://wiki.archlinux.org/title/Session_lock

1 Like

Oh nice. I’m gonna try out those xorg.conf.d overrides.

I’m also curious if this might fix my pet peeve with 5.11 and 5.12. Basically if I leave my thinkpads lid closed hooked up to HDMI and reboot the monitor stays blanked after reboot. Gonna play some with this.

1 Like

I suspect if you add the following to the file I mentioned above, this would take care of turning it all off - even if the lid is closed. Of course, I don’t know but seems logical.

Section “Extensions”
Option “DPMS” “Disable”
EndSection

1 Like