The issue about blueman notification with dunst

In archlabs dot file . config/first/dunstrc results the dunst can not using CTRL+Shift+. to select the activation when the Bluetman send notification

I try to replace it to the default dunstrc in /use/shared/dunst/*rc , it would be ok to return dmenu when I Ctrl + shift+.

Is it a real issue ?? Or it is a some special behaviour ?

Possibly could be an issue with dunst or conflicting keybinds? Just check your rc.xml to make sure that keybind isn’t in place for something else.

We don’t include dmenu with Archlabs, instead opting for rofi (dmenu compatible)

The config line command

dmenu = /usr/bin/rofi -dmenu -p "dunst:"

Should work, can you do what @Dobbie03 said and double check there are no conflicting keybinds (use the keybinds pipemenu to see quickly)

Then add the line as shown above and see if it works?

You might also want to change these lines

indicate_hidden = yes
show_indicators = no

Awaiting reply, Cheers

2 Likes
    [global]
font = Ubuntu 11
markup = yes
format = "<b>%s</b>\n%b"
sort = yes
indicate_hidden = yes
alignment = center
bounce_freq = 0
show_age_threshold = 60
word_wrap = yes
ignore_newline = no
geometry = "400x10-20+40"
shrink = yes
transparency = 0
idle_threshold = 0
#monitor = 0
follow = mouse
sticky_history = yes
history_length = 20
show_indicators = no
line_height = 0
separator_height = 2
padding = 10
horizontal_padding = 20
frame_color = "#c0c5ce"
separator_color = frame
frame_width = 1
startup_notification = false
dmenu = /usr/bin/dmenu -p dunst:
browser = /usr/bin/firefox
icon_position = left
icon_path = /usr/share/icons/gnome/16x16/status/:/usr/share/icons/gnome/16x16/devices/

[urgency_low]
background = "#2b303b"
foreground = "#c0c5ce"
timeout = 3

[urgency_normal]
background = "#2b303b"
foreground = "#c0c5ce"
timeout = 3

[urgency_critical]
background = "#2b303b"
foreground = "#bf616a"
frame_color = "#bf616a"
timeout = 5

This is my configure, I have changed to dmenu = /usr/bin/rofi -dmenu -p "dunst:" and change the context key to Ctrl+Shift+p, And I checked there is no confident keybind

But it still not working

Can you install dmenu with pacman -S dmenu, then try using the default entry as you have above
dmenu = /usr/bin/dmenu -p dunst:

Does it work with the defaults?

I think the issue may be related to the previous 2 options I mentioned

indicate_hidden = false
show_indicators = true

I’ve just tested it personally and it works perfectly fine, all I did was:

First edit dunstrc

dmenu = /usr/bin/rofi -dmenu -p dunst
show_indicators = true
indicate_hidden = false

Next I restarted dunst with the command flag -context_key (I chose ctrl+t)

pkill dunst ; dunst -context_key ctrl+t &

Then I used notify-send to test

notify-send 'Test' 'Example Websites\n\nhttps://github.com\nhttps://google.com'

I press ctrl+t and it opens a dialog where I can pick between actions

Google Photos

The same goes for using the default dmenu

Google Photos

1 Like

Oh ~yes
It works !

dmenu = /usr/bin/rofi -dmenu -p dunst
show_indicators = true
indicate_hidden = false
2 Likes

Once again, Smoke demonstrates his awesomeness.

A god among us mere men.

1 Like

Glad that worked

Cheers