The Intel HD Graphics 530 + GeForce GTX 960M Nightmare


#1

Hello guys, I have been trying to configure my graphics properly but i am not sure on how to do it. wiki is a bit confusing for me, talking about Optimus,bumblebee and im not sure what to do.
I installed the latest nvidia,nvidia-settings,bumblebee but i am not sure on how to proceed from there and even if i really need bumblebee. I am not sure on what the differences are between bumblebee and optimus.

lspci | egrep ‘VGA|3D’

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 530 (rev 06)
01:00.0 3D controller: NVIDIA Corporation GM107M [GeForce GTX 960M] (rev a2)

Dmesg:[code]
https://paste.pound-python.org/show/plfj5JJBceEQziNA2HXu/

[/code]
/var/log/Xorg.0.log[code]

https://paste.pound-python.org/show/Ywbh6hfsmCcv7XuCKQec/
[/code]
cat /usr/lib/modprobe.d/nvidia.conf

blacklist nouveau
cat /usr/share/X11/xorg.conf.d/10-nvidia-drm-outputclass.conf

Section "OutputClass"
    Identifier "intel"
    MatchDriver "i915"
    Driver "modesetting"
EndSection

Section "OutputClass"
    Identifier "nvidia"
    MatchDriver "nvidia-drm"
    Driver "nvidia"
    Option "AllowEmptyInitialConfiguration"
    Option "PrimaryGPU" "yes"
    ModulePath "/usr/lib/nvidia/xorg"
    ModulePath "/usr/lib/xorg/modules"
EndSection

/etc/mkinitcpio.conf

https://paste.pound-python.org/show/7KO9EBO5Q382erau4Lap/


#2

Optimus is the name given to the power-saving technology used in laptops whereby the Intel graphics card handles most of the display but farms out any 3D rendering to the NVIDIA GPU.

Bumblebee is the software in Linux that tries to make this work :slight_smile:

If you want to use Bumblebee with your Optimus laptop then remove the Xorg configuration file (you don’t need that) and refer to the ArchWiki page.


#3

This is largely up to you, honestly I would say that the 960M is only marginally better than the intel iGPU. Do you play a lot of games?


#4

so i could just add the 20-intel.conf file and isntall video.intel and thats it right? should be no need for nvidia at all


#5

In this case the nvidia chip will never be used regardless so there should be no need for anything else, for daily usage on intel graphics I would use the ‘TearFree’ option in a simple xorg config as shown here this avoids the need to mess with compositing vsync and just use the driver’s built-in.

# /etc/X11/xorg.conf.d/20-intel.conf

Section "Device"
  Identifier  "Intel Graphics"
  Driver      "intel"
  Option      "TearFree" "true"
EndSection

Then you can just do

pacman -Rns nvidia nvidia-settings bumblebee

You can make sure you have

pacman -S xf86-video-intel

and you should be golden. You can also remove any blacklists you might have created.

If you still want to instead set up bumblebee then let me first explain that the nvidia card will only run when you start a given opengl application with optirun so this isn’t any on-the-fly type of thing, secondly if you don’t use any applications that use opengl then the card will simply go unused regardless.


To set up bumblebee simply install the relevant driver, settings and the service itself.

pacman -S nvidia nvidia-settings nvidia-utils bumblebee mesa

Now your user needs to be a member of the bumblebee group in order to use it

gpasswd -a $USER bumblebee

The just enable and start the service

systemctl enable bumblebeed.service
systemctl start bumblebeed.service

To test it you can install the mesa-demos package

pacman -S mesa-demos

# try it out
optirun glxgears -info

All of this is fairly clearly documented on the bumblebee Arch wiki page.

Cheers


#6

ok so i decided to go without the nvidia. I installed xf86-video-intel and added the 20-intel.conf file ad thats it. X starts but if i logoff it then freezes the screen.
If i trye lspci the command freezes
my dmesg
https://paste.pound-python.org/show/LRp0O1npXbMOGch5pIMa/
i am booting with this kernel parameters:
nomodeset nouveau.modeset=0 i915.modeset=1 radeon.modeset=0


#7

how come there is no good support for this hardware yet… its like 2-3 years old alredy and still cant be configured easily… i tried to comment out the 20 intel file… still freezing


#8

I don’t know if all of this is needed, you don’t have a radeon card so that module will never be loaded, with the nouveau and intel modules, have you tried booting without these and can verify they are required?


#9

yeah those two are required, if i dont modeset them i get to X but if i try to get to the lightdm screen after loggin in X once it freezes the pc completely


#10

Unfortunate, I have a similar setup with HD530 but a 940M instead and It works nicely without any messing about (I just use the intel chip as the 940M is no better) , I’m not sure what the underlying difference is between the two setups to cause you to require modesetting, possibly a package difference. I’ll look into it more tonight, just on my lunch break right now.