Terminal xst (solved)


#21

Have you checked what the class of a given xst window is?

xprop | awk -F\" '/CLASS/ {printf "NAME = %s\nCLASS = %s\n", $2, $4}'

Just don’t use that on the terminal you’re running it in or you’ll get multiple outputs.


I also can’t overstate how backwards it is to use a tiling wm and set a terminal emulator to always be floating, let the wm do it’s job.


#22

Thanks, it turns out that in the configuration you have to put st-256color and it works.
Thank you very much, this forum is nice.


#23

Yes or modify the source files for (x)st

Not sure about xst but stock st uses the termname from config.h for the name, class, and TERM environment variable.

/* x.c */

void xhints(void)
{
    XClassHint class = {opt_name ? opt_name : termname, opt_class ? opt_class : termname};
    ....
}

----

/* config.def.h */

/* default TERM value */
char *termname = "st-256color";

So really the terminal could be called whatever you like but a few other things would need to be updated, mainly the terminfo entry.

Glad that solved your issue though, cheers


#24

xst stock uses:

static char *termname = “xst-256color”;

Which explains why either of these were working for me when I compiled it from source:

for_window [class="(?i)(?:xst)"] floating enable
# for_window [class="xst-256color"] floating enable 2pixel

#25

Thank you very much