Terminal Cursor is Always Set to Ibeam


#1

Hey guys, I’ve noticed on the new installs the terminal cursor is always set to an Ibeam. I’m assuming it’s some global setting and not per terminal config. I can’t for the life of me figure out where it’s pulling this from. Just wondering if anyone has found where to change this?


#2

Which terminal?

If it’s st, it needs to be recompiled like dwm; unless it’s patched with the .Xresources patch, then I think you can set the cursor shape there.


#3

urxvt

If I put

URxvt.cursorUnderline: true

It has no change from the Ibeam

I’ve tried all the terminals from the al-installer. First it was termite and I thought it was something screwy with vte the backend so I moved on to xfce4-terminal and finally urxvt to see something not vte based had the same effect.

They all are the same.


#4

Check the outputs of appres & xrdb -query to see what X resources are being set.


#5

xrdb -query is showing URxvt.cursorUnderline: true in the dump so it should be an underline cursor instead of the ibeam.

I tried a different .bashrc as well as disabling al-info which were my second notions that an escape sequence was doing it but to no effect.

I haven’t tried ST but I bet it’s different since it’s compiled and hardcoded


#6

I figured it out partially. It’s something in .inputrc If I delete that file it will take any cursor shape defined. Now I gotta figure out what line is doing it.

Edit:
.inputrc seems to be tied to the default archlabs vim config to reset the cursor shape to normal after using input mode in vim then exiting

So I guess you could delete .inputrc and use a different vim config to get around this issue.

I’m gonna mark this thread as closed since we seemed to have narrowed it down.


closed #7