Systemctl suspend runs i3lock?

hi all, I am not sure if that is default or I configured it a long time ago but I cant find why and how systemctl suspend runs i3lock

any help on finding how this is happening ? I relly need to chnage the colour of the background for the i3lock ?

Wonder if that can be of any help @stilia.johny . Unless you already had a look at this link;

I am trying to stop i3lock from running when I suspend

I think I used this article to setit up long time ago ( if I remember correctly ) but when I run systemctl suspend I still get i3lock running :confused:

Oh, lets see if someone can give you a hand in here.

its keep bugging me for few days, I looked on pretty much all the systemd services and timers and all, I cant find where I configured it :smiley:

Well , that sux, have a look in there;

1 Like

This might help you out also;

I think I found it …
wth… I had xss-lock in my i3 config as exec on load
exec --no-startup-id xss-lock --transfer-sleep-lock -- i3lock --nofork

Wonder why I couldnt find it on the write place, cause I had it on the wrong place :smiley: :man_facepalming:

1 Like

A good thing @stilia.johny

Lol, reminds me when one cleans up, one can t find anything afterward !

Or if one has too many things that couldn t be found !

1 Like