Superkey - Alt+F1 error

I will be following this discussion, tried some of the same things as @wammes. I also tried reinstalling ksuperkey, but with no luck.

I did some updates and rebooted the computer multiple times. I did not change any config file. The superkey has started working. It must be magic. Pressing the windows key now gives me rofi. I have no idea why it started working but I’m glad it did.

I also reinstalled it but to no avail. As I write in another msg the key has started working like magic. If it does, don’t press escape to exit it but choose a program first! After this it will keep working. It must have something to do with parts of xfce that are installed. (Wild guess)

Wonder if this link can be of any help here: Related somehow Edit: others can chim in on that

Edit: Might also depends on hardware used.

I think it’s this - having parts of Xfce running. I was having the same issues in bspwm. I commented out the xfsettings from bspwmrc and everything worked as expected.

I filed a bug report about it on the AL bitbucket page.


Thx for the solution here @PackRat

Somehow it’s a bug. I agree. Glad you reported it.

When I disable the xfsettingsd in openbox autostart all seems to work normal. However, my us intl with deadkeys keyboard is not remembered. I can solve this issue by editing the keyboard file in /etc/X11/xorg,conf.d but that’s only part of the solution. xfsettingsd is just needed to remember any setting you make. i.e. power management is also handled by xfce. Any ideas from @admin how to solve this issue gracefully? What exactly are the consequences by disabling xfsettingsd?

1 Like

I haven’t had any other issues since disabling it.

I didn’t get any feedback after filling the bug report on bitbucket.

I edited the /etc/X11/xorg.conf.d/keyboard file and have my intl-us-keyboard with dead keys working as expected. ë, é, ö So no problems there. No issues so far. We’ll see how it works out. Strange, that you did not get any repsonse btw.

I may have filed it incorrectly. I was in a hurry, had an appointment to keep.

As expected, the powersavings don’t work if I disable xfsettingsd in autostart. All in all, this distro has some ninor issues, but I find them annoying. The openbox setup looks absolutely gorgious and the keybindings are great! I just added one minor thing: switching desktops is much easier if you add keybindings for DesktopRight and DesktopLeft in rc.xml I binded them to C-W-Right and C-W-Left. I find that much easier than pressing the windows key plus 1,2,3,4 The keys are just to far apart.

@PackRat, did you file a report at the AL bitbucket? Can you link me please.

done; actually filed 2 issues.
sxhkd has some duplicate entries.

1 Like

Thanks @PackRat

3 posts were split to a new topic: Xfsettings not working

I have the same issue: after hitting ALT+F1 for a couple of times, at some point I get the error-message:

Failed to launch shortcut "<ALT>F1"
Failed to execute child process “xfce4-popup-applicationsmenu” (No such file or directory)

Though I don‘t know if this solves the problem permanently, I wasn’t able to reproduce the error after I changed the value for <Alt>F1 from ‘xfce4-popup-applicationsmenu’ to ‘rofi_run -r’ in the Xfce4-Settings-Editor.

Settings > Keyboard > Application Shortcuts, remove Alt+F1 bindings, done.

1 Like

The same problem occurs with i3.
The solution is to launch xfce4-keyboard-settings and delete every shortcut binding, since none work.


Yeah that’s the pain in the arse but it fixes the issue :smiley: